Can't create footprint in 5.1 or nightly

OK, cool. Many forums don’t allow videos to be uploaded but gifs still work. Anyhow, what about the actual issue?

I just tried what you are doing in a fresh kubuntu 21.04 vm, issue doesn’t reproduce.

Maybe you have some issue with the file system, it allows creating and listing files but not reading them? Is it a local fs? After creating the footprint can you open the file in a text editor and see some contents?

I would look for the new a_testfootprint in all the other libraries (i.e. all .pretty folders). Starting with the Electromechanical library.

Thanks for testing @qu1ck that’s a valuable info. So I need to figure out what’s wrong with my setup. What’s the best way to reset all the preferences?
There is nothing unusual with the file system.

KiCad stores all its preferences in a single directory Where are the configuration files (settings, library tables)?

Deleting its content should get you back to the factory setup. But this seems a bit like using an atom bomb to solve the issue so maybe at least make a backup.

I deleted all the preferences, purged kicad, reinstalled, still the same issue.
It works on a different computer with the same OS just as expected. I’m baffled.

Just tried a screen recording for another issue: File is too big for upload. Going to stick with compressed gifs.

Still not able to add footprints. I’m desperate for a solution.

on reopening KiCad I get

Moved the project folder to the desktop and now it seems to be working:

image

Will investigate later what the problem was. One umlaut in the path possibly?

If you will be able to narrow it down to specific root cause and report it here or even better on gitlab, you will help devs fix it.

Bug report here:

1 Like

So this is another unicode or alternate codepage vs ascii issue then?