Can't copy symbol in Kicad 6?

Hey all. I’m using Kicad 6, just upgraded from 5. I’m sure it’s going to be super awesome once I get it figured out but at the moment I’m very frustrated!!

I can’t seem to simply copy/paste a symbol, let’s say a resistor, that’s already in the schematic. I did RTFM (although maybe I’m just dumb…) . In Kicad 5 I used to simply hover over a symbol and press ‘C’. That worked well enough.

I noticed that the ‘C’ hotkey was no longer set to copy, so I changed it back to copy, still doesn’t work.

The manual also says I can hold shift/left click a component to copy. Not working either.

I can use ctrl c/ctrl v but there must be a quicker way. What am I missing?

edit I just noticed there’s a hotkey for “Duplicate selected schematic symbol” instead of copy that I should have assigned C to. Thinking that would clearly solve my issue, I changed it. Still not working!!!
Also version 6 manual says ‘C’ is assigned to that command by default, which it was not on my system.

Thanks!

I think the function you are looking for is called ‘Duplicate’

Yes, thanks. I actually just added an edit to my original post. I found that, but still not working!

Make sure you’re assigning for the ‘Duplicate’ command and not the other one.

Ahhh, thank you. That does work. Although that is still pretty frustrating. It’s not clear at all how those two commands are different.

1 Like

Shortcuts have been changed in v6 to follow more normal universal conventions (Ctrl+C etc.). C is now “Unfold from bus”.

It seems to be true that I can’t change Copy to plain C. It’s a bug and should be reported to the issue database.

The online version 6 manual lists ‘C’ as being the default hotkey for duplicate. Should I just assume much of this manual is out of date? Where else would I find a list of changes from V5 to V6?

Also, the ‘shift + left click to copy’ as stated in the manual does not work for me. Is it working for anyone else?

What is the difference between “moving selection” (left mouse button) and “dragging selection” (ctrl + left mouse button)? Moving would suggest to me that only a symbol would move and not the wires connected to it if that was all that was selected. Dragging would suggest wires would move also. But that’s not the behavior. “Dragging” just seems to increase the resolution of the grid when moving.

I just don’t get how I’m supposed to understand even the most basic functions of the program if at best the manual doesn’t fully explain them or at worst is just straight up inaccurate?

2 Likes

From what you write these are functions from version 5. Version 6 schematic editor does seem to work completely different. For me coming from v5 its a major pain in the arse. Initially wanted to make a fast upgrade but for me the tool is unusable. I really don’t know why mutilating a tools functions is in anyway helpful for the users.
Yes, I am frustrated.

1 Like

Hello @memsgrad

This should be Ctrl + D

@birdman

It is the behavior in my Kicad 6. Schematic.
D highlights but will only drag with left mouse key depressed.
G highlights and drags without mouse key depressed.
D & G are a bit different in PCB

Lots of users complained (rightly so, in my opinion) that KiCad 5’s default hotkeys didn’t match the OS standard hotkeys (such as ctrl-C for copy). KiCad 6 fixes this.

But, it’s software, and everything is a trade-off. :man_shrugging:

I agree with @snigg. I moved from v5 on linux to v6 on windows. The Ctrl+C for copying a symbol is a pain in bottom. Just My two-penneth.

1 Like

When I dicovered KiCad first (V4.?) I had to learn that this is the one SW that does NOT use CTRL-C. Now I have adapted to “c” I have to learn its now the standard CTRL-C.
Its just about what one is used to and I think in the long run CTRL-C will be the right decision…

… on the other hand, just “c” WAS Quick :stuck_out_tongue_closed_eyes:
NO, standards are better in the long run, POINT !

1 Like