Can't connect test point with components

Hi everyone!

As the title says I want to connect test points to the SMD pads. When I try it it just draw around the pad, but won’t connect it. I tried it with the pre intstalled footprints TestPoint_Pad_D1.5mm and TestPoint_Pad_1.5x1.5mm, none of those work.

How can I fix this problem?

Treat them just like any other component.

First create test points in your schematic, and then assign the PCB footprints for the test points to them.

1 Like

KiCad’s one of main tasks is to prevent you from making connections that do not match your schematic. Do that pins are connected at schematic?

1 Like

Yeah, they are connected. I attached pics abut the problem.

The netlist loader also says that It cannot add the footprint because of it’s missing. It strange, because I use the pre installed footprints.

What is a “netlist loader”?

Why can you show a footprint on the PCB if KiCac apparently can not find it?

If the link in the schematic does not work, then adding it manually to the PCB does not work properly either, because the netlist link will be missing.

So go back to the schematic, and figure out what the problem is over there.

1 Like

I was talking about the “load netlist” window in PCB designer.

It shows me the following error messages:

Error: Cannot add new symbol TP95 due to missing footprint .
Error: No footprint defined for symbol “TP104”.

I have no idea what mistake I made, I can connect other parts without any problem.

Can you post a copy of you assignment screen?


1 Like

Using external netlist file isn’t necessary, use Tools -> Update PCB from Schematic instead.

Show us the Properties dialog of TP95 and TP104. (EDIT: or the dialog shown by JohnRob, as long as those parts are visible in the list.)

1 Like

Update PCB from Schematic option worked. Thank you so much!

Anyway, I assigned every part.

That suggests bug in export or load netlist.

… or simple user error, such as reloading an outdated netlist.

It’s a new project, I lodaded the netlist right after I created it.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.