Can't connect pin header: "Track near thru-hole"


I have a pin header footprint on my PCB but can’t seem to connect anything to it. I tried both the upper and lower copper layer but the program always gives me the error in the title.

What am I doing wrong?

Is it possible that you used non plated thru hole pads instead of normal tht pads?

Hmm, not sure. I downloaded the footprint from DigiKey’s library. In the pad properties it says “Throug-hole”. Other pad type options which are available are “SMD”, “Connector”, “MPTH”.

Ok, I installed the latest nightly and now it works. Unfortunately, I have a slightly different issue now. The bottom layer +3V3 fill won’t connect to pin 1 of my header. There are tiny dents towards the pad but they don’t seem to go all the way through. The rats nest doesn’t disappear either.

Well what is the net you assigned to the zone? Is it the same as the one assigned to the pad number 1? (The full string must be equal. You get the full netname string for the pad via the pad properties dialog.)

What is selected for “Default Pad connection” in the zone properties menu?
What is selected for Copper Zone settings in the pad and footprint properties?

About the use of nightly builds: Be aware that there are dangers connected with using untested fast changing software

The fact there are partial thermal relief spokes suggest that the net is correct, and KiCad tries to connect the pad to the zone, but some clearance is preventing it. Or it’s a bug in the nightly - there have been recent changes to thermal reliefs.

Without more details it’s hard to tell.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.