Can't connect LM7805 on my board (solved)


I tried to place my LM7805 on the PCB board. I choose TO-220 footprint into TO SOT package. When i make net to place all components, l have always this message error for component U3, my LM7805.

Info: Vérification du composant de la netliste “U3:/59599E0F:TO_SOT_Packages_THT:TO-220-2_Vertical”.
Ajout du nouveau composant “U3:/59599E0F” empreinte “TO_SOT_Packages_THT:TO-220-2_Vertical”.
Erreur: Composant '‘U3’ pad ‘VI’ non trouvé dans l’empreinte ‘TO_SOT_Packages_THT:TO-220-2_Vertical’
Erreur: Composant '‘U3’ pad ‘VO’ non trouvé dans l’empreinte ‘TO_SOT_Packages_THT:TO-220-2_Vertical’
Erreur: Composant '‘U3’ pad ‘GND’ non trouvé dans l’empreinte ‘TO_SOT_Packages_THT:TO-220-2_Vertical’

After, i can’t connect wire into board manually. What can do about this issue ??


1 Like

I can not read what is not in English.

Assign again the footprint in Eeschema, or use CvPcb, and run the Netlist command there and then in PcbNew.

You are using an old symbol, that is not using pin numbers 1,2,3…


There is a problem mapping the pins from the LM7805 symbol in the schematic, to the TO-220 footprint on the PCB layout.

Open the schematic symbol in the symbol editor, and inspect the parameters of each pin. The Pin NUMBERS should be “1”, “2”, and “3” - not “VI”, “VO”, or “GND”. (These names may be used for the pin NAME, but not the pin NUMBER.) Change them if necessary, save the updated symbol to the correct library, AND REPLACE THE SYMBOL IN YOUR SCHEMATIC WITH THE CORRECTED SYMBOL.

If the schematic symbol is correct, verify that the NUMBERS of the footprint pads are also “1”, “2”, and “3” - and that Pad number 1 is in the correct location for the function of Pin number 1; Pad 2 corresponds to Pin 2, etc.

You will have a problem if the schematic symbol has THREE pins but the PCB footprint has only TWO pads. Try the footprint called “TO-220_Vertical” instead of “TO-220-2_Vertical”.



Gotcha !!! Wrong name pin. Now it’s work fine. Yes, i just try an other TO-220 but i know it’s TO-220 for the right footprint.

thank a lot guy !!!

If you have the official footprint lib there should not be any TO-xxx footprint in there with non numeric pin numbers. (Assuming you are not running local libs that have not been updated in a while. Out of the box you always have the newest footprint versions.)

The problem in that case can only be on the symbol side. This could be because you have a very old kicad version or you did not update the library when installing the new version. (The current version is 4.0.6. If your version is older than 4.0.5 you should really update now.)

If you find a footprint in the lib that still has non numeric pin names, this is a bug. We would like to know which footprint has this problem. Either post the footprint name here or better still open an issue over at the kicad library github repo in question. (I’m talking about normal IC packages. Relays, switches, … can have non numeric pin numbers if they have a specialized symbol that uses this footprints.)

Just found this thread having come across the same problem.

I have an install on Linux and the newest version seems to be 4.0.2 if installed via the package manager, be sure to go to the Kicad website and get the latest version 5.x

Hopefully this will fix the problem for me too :slight_smile: