Can't change the track width


#1

I’ve created different track-widths in the design rules, but when I want to change the size of a particular track the only option I get is the default size; shouldn’t I get the other design-rule options also? The dropdown box at the top left doesn’t give me any other option either. I use KiCAD 4.0.5 on macOS 10.9.5, and I had the same problem with KiCAD 4.0.2.


#2

You made a couple of netclasses with different track widths… you now would need to assign different nets to those classes - this is probably not what you want.
What you did is made for laying down high power and digital tracks with their own set of specs…

What you need is in the Global Tab…


#3

Thanks, that solved my issue indeed. I find it all very confusing, why is it not necessary to specify a clearance with these tracks? And why these separate rules? Why not use the netclasses as global rules also?


#4

As I said there are 2 cases there:

  1. you want to lay down tracks for high voltage with large clearances and thick tracks while also laying down digital signal tracks with small tracks and tiny clearances.
    To do this fast & safe one would create 2 netclasses and usually leave the digital stuff to Default and the nets which need the other settings would get their own class.

  2. you want to lay down tracks and change the trackwidth (not clearance or other settings as well) on the fly, that’s when you set up tracks widths.