Can't assign footprints

Hi guys,

it’s the first time i’ve used it (i’m doing an introduction), and currently i get stuck assigning footprints to components with cvpcb.
The problem is this: I only want to assign/assign footprints to components, but cvpcb does not suggest footprints.
I tried using all combinations of filters.

Am I just stupid or is it a bug?
Maybe someone can help me.

I’m using kicad version 5.1.6

1 Like

Hmm… I show 78 with the ‘filter by library’ selected. (look lower left for reference). You have tried all off? What OS. You show footprints in other libraries OK?

You seem to be using some Linux. Have you installed the libraries, too?

Open Preferences -> Configure Paths. What does it show? Give a screenshot which shows all lines.

Then, what does Manage Footprint Libraries show? Again, attach a screenshot. I want to see Path Substitutions section there, too.

hi, i use Arch Linux.
This is the first screenshot: library

Thanks for helping me and excuse the late answer, please.And this the second:

I needed to create two posts, because I’m a new user…

Thanks for helping me and excuse the late answer, please.

There’s something non-standard in your library setup. You have added the libraries to the global library table manually:


While in a standard setup it looks like this:

My guess is that you don’t have files in ~/Downloads/kicad-footprints/.


you’re right. I downloaded kicad-footprints and added it manually. it is just a temporary solution. but today i don’t want to deal with such problems :wink:


I learned that with every minute saved now with a temporary solution future me loses hours. So i really suggest to handle such core things like library management with care from the very first moment. If you are lucky you will never learn why this is a good idea (only costly mistakes can teach you that and proper handling avoids them).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.