Can't asign my Footprint in "Footprint assignment tool"

Made a shorter video.

Hello @JacobW

You probably won’t get many responses to a five minute video of a mouse dithering.
Written words work much better, with perhaps a very short video, or a screen grab, to help explain.

1 Like

Hard to explain for me!

I second jmk in that a good description (maybe with an additional video) beats a sole video.
I also have no real clue what the problem is.
Here are just some keywords I could think of:

  • annotate schematic before using cvpcb (footprint assignment tool). not necessary, but helps to find the part in the long list.
  • in the symbol-definition be sure to have (not 100% necessary, but recommended as good practice:
    • symbol-editor → symbol properties dialog → second pane “Footprint Filters”: add a filter-string which covers your new footprint. If you are unsure you could add a filter-string which exactly matches your custom library:footprint for the dcdc-module
  • in cvpcb: notice the three icons in the middle of the top toolbar (next to the bold text footprint filters:
    • filter by footprint-filter-string defined in symbol (therefore the step above)
    • filter by number of footprint-pins (count of symbol-pins == count of footprint-pads). (remark: this is not 100% reliable!)
    • filter by library (the library selected in the left pane of cvpcb)
    • currently the library-filter-icon is always active (like in your video) so you get only the footprints from the selected library
    • if you want to get all footprints shown (this will be a long long list): deactivate all 3 filters
  • in cvpcb: the right column updates/shows the corresponding footprints only if you select (click) on a symbol. So scrolling to your dcdc-symbol will not show any footprints, you have to click your dcdc-symbol (second column in cvpcb)

Me to.
I aborted 5+minute long first video after about a minute, but I did manage to sit through the 1:19 video.

You are abusing the RefDes for something that it is not meant to be used to. Do not use fancy names in the RefDes, but only use a letter and a number, such as C42 for a capacitor or R33 for resistors etc. If you want to add additional information, then add custom fields to the schematic symbols.

Adding a hash sign ([Shift + 3] “#”) to the front of a schematic symbol suppresses the schematic symbol from the BOM or PCB.

From the Schematic Editor / Help / Help

The symbol reference is #+5V. The reference text is not important except the first character which must be # to indicate that the symbol is a power symbol. By convention, every symbol in which the reference field starts with a # will not appear in the symbol list or in the netlist and the reference is declared as invisible.

But I did not add that. I eaven tried to delete that. But it will not go away.

Upload the archived project containing at least the problematic dcdc-symbol in the schematic and the corresponding footprint in the board (insert the footprint manually with “add footprint”-icon).
This will allow us to investigate, all other attempts are only guessing games. (with a more or less educated guess).

educated guess: the checkbox “power symbol” is set for the dcdc-symbol in the symbol-editor. This is false.

Will do that as soon as I get home.

the Refdes of this part is: “#1.23-30V0101”. Change that into something like A42

And indeed, if the symbol is defined as a power symbol as mf_ibfeew mentioned then the hash gets added automatically. The setting is in: Symbol Editor / File / Symbol Properties / Symbol / [ ] Define as power symbol

I did this and now it showes up!

Thank you.

Did not have to change the name.

Is it becose I defind it as a power symbole?

It’s partly because of questions like this that I do not want to put much effort in your questions anymore. In fact, I opened KiCad help files, searched through it and cut a section out of it and posted it in aprevious post in this thread that literally has the answer to that question. Can't asign my Footprint in "Footprint assignment tool" - #5 by paulvdh

Start making pcbs is hard.

The learning curve is steep.

But it is fun that you can make it, get it product and have in your hands.

Why not embrace that?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.