Can't adjust pours


#1

Hi,
I have had multiple problems with selecting and editing a pour. The line of the pour is infinitely small so when i zoom in it stays thin. The only way for me to edit the pour is to select a large area that contains the entire pour and then filter select. I think the outline of the pour should have a fixed width as well so you can click on it and edit. I’ve had a few times where i can click on the pour and i can edit it, but it seems to be random to me.

P.s. I found the problem, you need to go to show filled areas in zones and from there you can adjust it. Perhaps this functionality can also be added for when you are not in this setting?


#2

First you will have to provide which KiCad version in use otherwise the answer is anyone’s guess.


#3

Press and hold the mouse button. Draw LEFT so that the blue selection box overlaps the edge of the zone.

I don’t know why, but I haven’t had problems with selecting zones. The width of the selection-active edge have been wide enough for me.

The problem with always selecting is that it becomes cumbersome very fast when you notice that you will select zones by accident, especially when it’s not visible and you move and delete it even though you didn’t mean to.

https://bugs.launchpad.net/kicad/+bug/1796118 could help, if zone color would be semi-transparent you could keep the zone fill visible.