Can't add footprint to library

When I try to save my footprint I see only the read-only default libraries and not the one I just created, even though it shows up in footprint libraries window. Very frustrating.

With such question you should always paste exact KiCad Version info you can get from Help - About KiCad. For me it tells not a lot but for others it is ‘must know’.
Have you closed Kicad and run once more after inserting your library into list. If not - try. I think it can sometimes help with such problems.

Sorry, here’s the version. I will try to restart but not being able to save to a global library w/o a restart seems like a bug lol

I was able to save to the project library but I want it in global so I will try this soon.


Application: KiCad Schematic Editor x64 on x64

Version: (7.0.0), release build

wxWidgets 3.2.1
FreeType 2.12.1
HarfBuzz 5.0.1
FontConfig 2.14.1
libcurl/7.83.1-DEV Schannel zlib/1.2.13

Platform: Windows 11 (build 22621), 64-bit edition, 64 bit, Little endian, wxMSW

Build Info:
Date: Feb 12 2023 01:35:19
wxWidgets: 3.2.1 (wchar_t,wx containers)
Boost: 1.80.0
OCC: 7.6.2
Curl: 7.83.1-DEV
ngspice: 39
Compiler: Visual C++ 1934 without C++ ABI

Build settings:

If you run KiCad version 7.0.0 that means that you want to help to fix bugs that each x.0.0 version has a lot. You shouldn’t be surprised that you’ve probably found one. Check if behavior you see is repeatable and report a bug.
I have not updated to V7 yet so I can’t check how it works for me (specially that I am now writing from Win7 PC so V5 is the last I can run here).

I think I reproduced this, but you did not write down which steps you did, so I can’t be sure.

First I did: PCB Editor / Preferences / Manage Footprint LIbraries, clicked on the plus and added the “MyFootprints” to the library table.

After that:
Footprint Editor / File / Save As…

And then it listst them in alfabetical order:

I hit the New Library button in the Save As dialog as shown in your screenshot

Hi @hph

There is a blow by blow account for setting up personal libraries in the FAQ here.

It may be worthwhile comparing your installation to the FAQ in case there are discrepancies between methods.

1 Like

I think one reason it didn’t work for you may be because New Library doesn’t create the directory that will hold the footprint files, only an association in the footprint library table. Arguably this should be an option in the UI.

Thus you should create the directory ahead of time following jmk’s FAQ.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.