Cannot view Silk screen on copper pour

Hi all,
If you pour copper under a footprint, the silkscreen becomes invisible.
Can you bring bring that silkscreen to the front so that you can see it?
I tried several combination on the layer manager without any luck.
Thank you.
Regards

In v6 the layer you choose in Appearance → Layers becomes the front layer in the view.

You can make zones semi-transparent in the Objects tab, which is good for normal work even if the Silk isn’t a problem.

1 Like

Thank you for your reply.
Are v6 files compatible with v5?
Can you install both version on the PC?
Regards

You can convert projects in 5 to 6 but you can’t take them back to 5.
You can have 5 & 6 both installed on Windows. It is apparently a bit messy to install both in Linux, I believe.

Thank you for the quick reply.
What happens to the custom libraries? Will they merge when you convert?
Regards

You will have to add your custom libraries with Preferences / Manage Symbol (Footprint) Libraries.
With the symbol libraries you will also have to click “Migrate Libraries” (which converts 5 to 6)… just above the OK button.

It is worth making a copy of your Kicad 5 libraries in a different place in your computer in case of stuff ups. Also use these copies (that are in a different folder in your OS) to place in your 6 libraries, otherwise you will have to then point your Kicad 5 to this copy as your originals will be converted to 6 and no longer usable in 5… I hope this is clear. Reply if you don’t understand please.

So:
Create new folders with your OS. One for symbols, one for footprints.
Copy all your personal libraries into these appropriate folders.
Add these libraries to your new Kicad 6 with Preferences / Manage Libraries.

1 Like

Thank you to all of you.
This makes very clear what I have to do.
Regards

I was experimenting with V6 in February.
From that time I have a note that with first run I was asked to let KiCad initialize library list from V5 library list. The only problem was that I had to find the V5 library list file. But as I know (Windows) they are in Users\Me\AppData\Roaming\kicad I had no problem with that and I had library lists ready without need to make them from scratch.

Hi @Piotr ,
FrancescoC was writing about his “Custom Libraries”, that is, his “Personal Libraries” which are placed wherever a user wishes, not the specific place that Kicad Supplied Libraries inhabit.

I use only my personal libraries placed in my working directories, and running for first time KiCad V6 I was able to point for library lists files from V5 and they were adopted by the V6 and copied to its working directory. As I was doing it in February I don’t remember step by step but I have a note in my (not finished yet) V6 cheat sheet.
Now I have V6 installed nowhere so can’t check it. I was waiting for 6.0.6 thinking that when it comes I will start to move to V6. Writing this post I just checked and I found 6.0.6 !!!

Ha!! No excuses now for not upgrading. :slightly_smiling_face:

I too only use personal libraries, but I also have Kicad libraries installed so I can copy and modify those Kicad parts to place in my personal libraries when necessary.
I keep personal libraries on a separate, data only, “D” drive and backups on an “E” drive and USB stick.

1 Like

This is a convenient solution that I also use.

I have copied all my KiCad files from my Win7 PC to Win10 PC.
I have also copied files from C:\Users\{me}\AppData\Roaming\kicad to the same directory at Win10.
I installed KiCad 6.0.6.
At first run of main application I selected to Import settings from one of previous versions - by default it looked for them in AppData\Roaming\kicad so just accepted it.
At first run of Footprint Editor I tried to select “Copy custom global footprint library table” but I could’t point to table in AppData… as I didn’t saw hidden/system files. So I copied fp-lib-table and sym-lib-table to D:\Tmp directory and selected fp-lib-table from there - it worked.
At first run of Symbol Editor I selected “Copy custom global symbol library table” and selected D:\Tmp\sym-lib-table.
When tried to open any symbol was directed to run Manage symbol libraries where I was able to select all of them and “Migrate Libraries” in one step. All my aliases was changed to symbols “Derived from symbol”.
Now it looks everything is working. Each schematic and PCB needs to be saved to save it in new format.