Cannot use pin headers for some reason

I am seeing this issue here. I am not sure what is going on. I just want to add a pad/pin. For that I am trying to add any Conn_01x but I cant for some unknown reason.

Testing other footprints randomly and they work without issues

You have to have both library name and footprint name.

I am not sure if I understood your reply.

For instance.
I am selecting the footprint: PinHeader_1x01_P1.00mm_Horizontal

I receive this popup when I click Ok.

Is this a problem with the library/footprint or with Kicad?
Can you check if you can use that footprint?

Application: KiCad Schematic Editor x86_64 on x86_64

Version: 7.0.0-da2b9df05c~171~ubuntu22.10.1, release build

	wxWidgets 3.2.1
	FreeType 2.12.1
	HarfBuzz 2.7.4
	FontConfig 2.13.1
	libcurl/7.85.0 OpenSSL/3.0.5 zlib/1.2.11 brotli/1.0.9 zstd/1.5.2 libidn2/2.3.3 libpsl/0.21.0 (+libidn2/2.3.2) libssh/0.9.6/openssl/zlib nghttp2/1.49.0 librtmp/2.3

Platform: Ubuntu 22.10, 64 bit, Little endian, wxGTK, ubuntu, x11

Build Info:
	Date: Feb 27 2023 09:24:07
	wxWidgets: 3.2.1 (wchar_t,wx containers) GTK+ 3.24
	Boost: 1.74.0
	OCC: 7.6.3
	Curl: 7.85.0
	ngspice: 38
	Compiler: GCC 12.2.0 with C++ ABI 1017

Build settings:

Works for me. KiCad 7.0.0.

you have to click Ok in the Symbol Properties window.

Footprint assignment worked fine.

If you look carefully at the dialog’s Footprint field in the examples which work and don’t work you’ll notice a difference. The field must have the library name first, then ‘:’, then the footprint name. You didn’t give enough context to tell what might be wrong, and what you wrote is ambiguous from this viewpoint. Did you copy and paste the text? Or opened a footprint selector?

1 Like

Ah, I see. The issue is the missing library from the footprint name.
I did not type anything.
I just clicked the icon on the right of the field. Then I selected both footprints from the list. For the problematic footprint, the library is not coming from the footprint selector window then.

It would be good to find out why. It may be a bug. Can you say if there’s anything special with your library setup?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.