Cannot start routing on keepout area or board edge (no net-tie, no round shapes))

Hi all,

I have produced a custom footprint for a prototype that has to be bonded onto my PCB. I was having some trouble getting all the signals out because the design is pretty crumped up on one side of the prototype, so I decided to modify the footprint a little bit to redistribute some connections. To my knowledge/understanding, all changes made to the footprint are either repositioning already existing pads or add/repositioning/shortening graphic lines in the F.Cu layer. However, when I went back to my layout and updated the footprint for the new version it couls not be routed. When I try to start a trace at one of the pads of the footprint I systematically get a “Cannot start routing inside a keepout area or board outline”, and when I come with a trace from some other point of the board, the pads are avoided even though the belong to the same net and the ratsnest is displayed. Non of this issues had appeared with my first version of the footprint.

I have made a very simple proyect whit a couple of instances of the prototype, each using a different version of the footprint to exemplify the issue, but I am not allowed to upload files because I am a new user. I tried to copy here below the content of the *.kicad_mod files but I reach the maximum character limit for new users. I have also included a few snapshots of my test project to try to ilustrate the issue but I’m only allowed to upload one, so it is a failing pad.

I hereby certify that I am not simply asking someone else to design a footprint for me.

This is an auto-generated message that is in place on the “footprints” section of the forum. If I remove it and ask for a footprint to be designed anyway, I understand that I will be subject to forum members telling me to go design my own footprint or referring me to a 3rd party footprint site.

My trust level was updated, so I can upload files now, so I take this chance to leave you here my small test project with both version of the footprint. (245.7 KB)

You have used graphic lines (segments) in the footprint. When it goes into the middle of the pad and you try to route it, it causes DRC violation. You can make them shorter so that they only touch the pad enough. Because the pads are long they will avoid the clearance rules when tracks are routed from the center of the pads.

You can also make custom pads. Select one pad and the connected segment. Open the context menu and use Create Pad from Selected Shapes. Then you will have one long pad which can be routed normally. But this will strip off the mask from the segment. If you don’t want that, you have to turn off the mask layer from the pad and create a separate aperture pad for the mask layer. The same is true for the paste layer. Therefore the first option with segments is easier in this case, although it’s not always possible for different kinds of pads.

1 Like

I shorted the graphic lines and now the issue is gone.
Thanks a lot for the quick response.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.