Cannot save in new global Library for footprints

I cannot create a custom library to store new pcb footprints in, my file menu is missing the option to save this footprint in a new library and the new library I created with the .pretty extension is not available to save the footprint in when I just try to go File->save as

I have included my new library in Preferences-Manage Footprint libraries menu

What the hell am I doing wrong?

Hello and welcome @eoin_oc

There is a new FAQ on personal library creation here. (link to FAQ at the top of this page in blue)

Worth reading and compare to your method.

Eventually I gave up on the global option, it would not work, but the project based library worked fine. I suggest Kicad should make the global option just as easy

Global is one of those slightly ambiguous terms here. It doesn’t mean it should be stored in a system directory. It just means it’s available to all your projects. This is achieved by putting your stuff in a directory that’s writable to you.

TL;DR: Don’t try to store stuff in system directories. Windows users got into this bad habit from the days when there were no accounts and the user could write anywhere. Unix and Linux users have always had user accounts and partitioned permissions.

Did you follow the FAQ?

What were you unable to understand?

I am referring to the naming from Kicad itself


No matter what I do if I follow the global option, the library I create never appears in my library list after I add it using preferences-manage footprint libraries.

If I select Project, it works, however the option in the file menu described here to save to a new library does not exist in my Kicad.

Have you read and tried the method I posted above with the link to the FAQ.
I used the abreviation “here” for this:

The very last paragraph explains that footprint libraries are made the same way as symbol libraries.

That sparkfun tutorial doesn’t describe how to make a library, just how to make something to place in the library.
That Sparkfun tutorial is incorrectly titled.
This is their first sentence: This section will show you how to create your own local custom footprints

Sparkfun tutorial you linked is for v5. You are using v6 (as you should) and it has significant differences in UI.

This may happen if you already have a project library with the same name, it will silently override global library.

Try what you are doing in a new empty project, global library should show up.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.