Cannot open KiCad 5 footprints with footprint editor

Using KiCad version 5.0.2. Please read this entire post before responding. I have completed my schematic design with Eeschema am encountering difficulty as I try to start my pcb layout. I want to open footprints with the footprint editor, as I probably want to edit them.

  1. I cannot find a fp-lib-table.

“One option is to remove the full fp-lib-table in your users config directory and let kicad replace it with the default one coming with the v5 libs.” Please explain in detail how do I do this?

I also cannot find the footprint libraries manager as described in Pcbnew help:

2.3.4. Adding Table Entries using the Libraries Manager
The library table manager is accessible by:
2) But I have copied a large bunch of Kicad Sourced .pretty modules:

and I have specified paths in the footprint editor:

But when I open the library browser I cannot see any of this. It is stuck on some footprints which I made a few years ago with KiCad 3.x(??) and are in a different folder which is not shown in the screen shot above. Why is this?

What is the likely problem?

[quote=“Rene_Poschl, post:2, topic:15418”]
Official KiCad documentation:

Thank you, Rene

Right away I run into this:

I will continue to work on this based upon your input.

Hi BobZ,

appaently the address of the documentation changed to reflect the version, here is a working link:

Yesterday I was looking for some "table" files (in my libraries folder and in my project folder) and could not find them. Today I found those along with the program files and copied some of those to a new folder in with my libraries.

I cannot find an "add library" button in the footprint editor. However, I did find Preferences > Manage footprint libraries and am now going with that so I think I now can get and edit footprints. My next challenge is figuring out how to produce a board outline.

Thank you, der.ule

That works!

Are you talking (typing) to yourself? :slight_smile:

It’s in:

Footprint Editor / Preferences / Manage Footprint Libraries.

Same menu is also in Kicad, Eeschema, Symbol Library Editr, Pcbnew, (others?)

Hi, Paulvdh

Don’t give “talking to yourself” short shrift. :slight_smile: I wanted to thank der.ule for his correction of Rene’s URL for help files. Also there was a comment about an “add library” button and I saw none such so maybe that can be corrected somewhere. Also I wanted to say that I am not still lost in pcb layout nowhere-land. However I would like to see some comment about how to set down a pcb outline. Right now I am assigning my own footprints to my schematic symbols.

I gave yo a roadmap to that just below “Are you talking to yourself” :slight_smile:

The outline of the PCB is defined by drawing lines on the “Edge.Cuts” layer.
First make the “Edge.Cuts” layer active by clicking just left of the square before the Yellow “Edge.Cuts” text.
The little blue triangle makes the layer active.

Then you can draw lines on that layer with:

Pcbnew / Place / Line

You can also use Arc’s on the Edge.Cuts layer.
Make sure that the endpoint of a line segment meets the coordinate of the startpoint of the next line segment. This is easies done on a coarse grid.
(Coarse grid will also make drawing horizontal and vertical lines easy).

You can also read the Pcbnew manual, chapter 6:

I understand that Preferences>manage libraries gets the job done. But it is not an “add library” button so I think that instruction should probably be revised. Thanks for your other comments…

May I ask where you found a reference to an “add library button”?
It’s been a sore thorn in my eye that the “Getting started with KiCad” manual is still referencing KiCad V4.0.7. KiCad V5.1 is expecteded within a few weeks and i’m seriously thinking about updating the “Getting started with KiCad” manual.

Hi, paulvdh Please see:

I can understand that keeping up with stale links and other such information is a real challenge. But this did get me stuck for a while.

I should add that the link

at the top of that same page does not work. A few days ago I was given an updated one…

I updated the links. This seems to have changed very recently as i wrote that tutorial only a few months ago and did edit it just recently (The links to the official docu where added sometime in January.)

Hi Rene

I tried to reply with a simple “Thanks!” but the website decided that that was too short.

Paulvdh: Somewhere we were discussing my use of fat corner pads (SOIC, TSSOP, etc.) to make hand soldering easier. I have made a couple of these footprints now. One way to maintain normal pad-pad spacing is to position the pad differently. But I find that the offset capability is nice. Basically (I think?) it allows me to define the “position” of the pad as a point which is offset from its center. Here is my “bigfoot” SOIC-14.Bobs_SOIC-14_Bigfoot_1.kicad_mod (3.3 KB)

That is pretty much what the offset does. Think of the anchor point of the pad as the center of where the drill hit would be (if your SMT pad was a THT pad). The offset allows you to move that anchor point off of the geometric center of the pad. For the fat corner pads, using the offset would reduce the mathematical complexity of positioning your pads.

Note, however, when routing your board with pad-snap turned on, I think the traces will snap to the anchor point of the pad, not the geometric center. But, I think thermal reliefs are calculated from the pad geometry, not the anchor point. I could be wrong on one or both points though. Some experimentation (that I don’t currently have time to do) would tell you for sure…

One can enter mathematical expressions directly into the position fields (In fact i think all fields should accept expressions now. If you find one that does not in nightly then report it as a bug.)

Apart from mathematical expressions such as 2.2+0.4 you can also enter units strings such as mm or mil after a number, and it gets translated to the current viewing units.
I’ve just been experimenting a little bit with:

Footprint Editor / Pad 'e’dit / Custom Shape Primitives

Before you can edit properties there you first have to set “Shape” in the “General” tab page to “Custom”. The options seem powerfull, but hard to use. I get the impressiont this part is not finished yet.