Cannot Open eeschema v6 (MacOS Mojave)

I just downloaded the new stable release of v6. I’m running MacOS Mojave 10.14.6. I can open the project manager, PCBNew, and the utilities, but any attempt to launch eeschema, from the project manager or standalone (with or without right-click-Open), results in this error:

EDIT: OK, I see that Mojave isn’t supported, so maybe that’s the problem :frowning:

The ReadMe that comes with the download says to “click and drag the two directory icons to the targets pointed at by the arrows”, but in my downloads (from both global and CERN) there is only one directory icon.

The ReadMe also says “The backup-kicad script in this disk image will attempt to do this. Right-click on the backup-kicad file, and select Open to run it and create a backup into your home directory.”, but there is no backup-kicad script in the disk image as far as I can see.

1 Like

Please ignore the Readme, it was supposed to be removed from the DMG but got left in accidentally.

We are unable to do any testing on 10.14 anymore and I think there may be other problems, unfortunately. It is difficult to support more than a few macOS releases given how often stuff changes/breaks and how few people are working on it.

1 Like

Hi There, I just installed KiCad on Windows 10 and have the same problem.


The problem only appears with the schematic editor and the symbol editor.


Not sure it helps but it works ok here on Mac OS 10.14.6 (18G9323)

So I am not sure what I have installed/configured that you don’t @JuliaTruchsess

I never used this system with the nightlies, but I have been using those on another one running 10.14.6 (18G9323) without issue for around 6 months now.

1 Like

Good to know it may not be Mojave, because I don’t really like upgrading my OS unless I have to. Now I’m in limbo waiting for the problem to be verified, especially if it happens under Windows, too (I use both OSs). Sticking with 5 for now.

Are you using 32 or 64 bit version?

There is no 32-bit MacOS version. I haven’t tried it yet under Windows.

I use a 64 bit system

OK so no luck there… stoull is related to long long conversion to string so my shot was that it might be related to kicad’s “bitness”.

Has this issue been reported on gitlab? If not, create an issue here:

If I report my MacOS experience, it will be ignored because I’m on an unsupported platform.

Much better if @Dico files a bug report for his experience under Windows.

Perhaps, but regardless of who creates the issue, it should be noted in the issue that the problem occurs on (at least) two operating systems, for (at least) two users.

I am facing the same issue on MacOS Monterey version 12.0.1
Screenshot 2022-01-02 at 8.18.30 PM

1 Like

This bug is reported at KiCad Error - Application failed to load. Error loading editor. stoull: no conversion (#10211) · Issues · KiCad / KiCad Source Code / kicad · GitLab

Everyone who is facing this issue, please report it so that it can be resolved at the earliest.


Thank you!

Did you find any workaround other than rolling back the update?

No, I’m staying with 5 until the issue is resolved.

Getting “stoull” error on Windows 10.

EDIT: I added “Field Name Templates” in 5.12, after deleting that line from eeschema file under “C:\Users<user>\AppData\Roaming\kicad\6.0” folder the problem got fixed.

That’s great news that you were able to fix the issue, but it’s not quite clear from your post exactly what you did. Can you please describe the fix in more precise detail? Thanks!

This issue is fixed in the 6.0 branch (and will be released in 6.0.1 eventually).

The issue was that 6.0 couldn’t handle anything in preferences with a . in it (now fixed). 6.0 preferences could end up with a . in them if 5.x preferences were imported and the old preferences had a ., for example a Field Name Template with a . in it. The example in the gitlab issue is LCSC Cost P.U..

For now you can work around it by starting from brand new preferences (delete your preferences and don’t import your 5.x preferences). Or you could be a bit more surgical and go through your preference file, find the offending bit, and delete it – I think that’s what @lightpower did. The specifics will depend on your preferences.