Cannot find libraries in MacOS 10.15

I still cannot get the libraries to work under MacOS 101.5.

I have followed the FAQ entry for adding the symbol libraries: the library path is correct, in that it is pointing to /Users/xxmyusernamexx/Library/Application Support/kicad. The libraries (all 6GB) all copied across after I authenticated folder with my user password.

The Symbol Editor window shows all of the libraries there, but nothing under each entry. I have tried re-loading a library from the library manager, but it tells me the library already exists.

When I started the program, it told me the libraries did not exist, so I clicked through each one individually, receiving the ‘loading’ progress window.

Not are what I else I can do? Is the issue that the individual symbols are just not associated with the libraries?

Thank you,

Jonathan

Hi Jonathan,

You didn’t say which version of KiCad you are using. Can you clarify?

I have used both KiCad 5.10 (stable) under macOS 10.15 and KiCad 5.99 (nightlies) under macOS 12.0. I am currently using macOS 12 with the following:

Application: KiCad

Version: (5.99.0-13123-g97e9348ee1), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.77.0 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.42.0

Platform: macOS Version 12.0.1 (Build 21A559), 64 bit, Little endian, wxMac

Build Info:
Date: Nov 6 2021 19:35:37
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.3
Curl: 7.64.1
ngspice: 35
Compiler: Clang 12.0.0 with C++ ABI 1002

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

I see that your library path is different than I got using a default installation. See my path configuration below (from KiCad menu -> Preferences -> Configure Paths…):

With these paths I have the following global libraries installed and active as shown below (from KiCad menu -> Preferences -> Manage Symbol Libraries…):

And the following project specific libraries for the KiCad demo project I have open.

If I open the symbol editor (either from the KiCad main menu -> Tools -> Symbol Editor, or Schematic Editor main menu -> Tools -> Symbol Editor, or the equivalent buttons or shortcut keys), I can display and edit the first component in the first library, the 4xxx:4001 as shown below.

I would suggest uninstalling KiCad (delete /Applications/KiCad, ~/Library/Preferences/kicad, and /Library/Application Support/kicad) and reinstalling using the default paths. Note, to install the kicad support files you need to open the Application Support folder using the alias on the installer disk image to display the contents of that directory, then drag the kicad support folder to the open Application Support finder window (rather than dragging it over the alias on the disk image). You will be prompted for a password to allow copying files to the protected directory.

On first launch of the schematic editor and the PCB editor you will be prompted about how to create the symbol library table or footprint library table. Accept the default option to “Copy global default symbol library table” (or the equivalent for the footprint library table). You should now have working symbol (and footprint) libraries.

HTH

Hi Jonathan,

After my last reply I decided to try out the latest nightly (the 6.0 rc1 version).

Application: KiCad

Version: (6.0.0-rc1-46-g1d2fd6d271), release build

Libraries:
wxWidgets 3.1.5
libcurl/7.77.0 SecureTransport (LibreSSL/2.8.3) zlib/1.2.11 nghttp2/1.42.0

Platform: macOS Version 12.0.1 (Build 21A559), 64 bit, Little endian, wxMac

Build Info:
Date: Nov 17 2021 17:58:35
wxWidgets: 3.1.5 (wchar_t,wx containers)
Boost: 1.76.0
OCC: 7.5.3
Curl: 7.64.1
ngspice: 35
Compiler: Clang 12.0.0 with C++ ABI 1002

Build settings:
KICAD_USE_OCC=ON
KICAD_SPICE=ON

I see that they have revised the installation method to eliminate the Application Support directory. The new installer disk image has only the KiCad application directory:

When I installed this version by dragging the KiCad folder over the Application aliens, I replaced my previous version. On first launch I was asked if I wanted to import my preferences from my previous version (5.99) or start fresh, so I selected the fresh install.

After that my paths were as shown below. Note the symbol and footprint libraries are now in the /Application/KiCad/… folder rather than /Library/Application Support/…

Then I opened a demo project and opened the schematic editor and PCB editor in turn. Each program prompted about creating the default libraries tables as before, and I selected the default option to copy the global default library tables. I can edit both the schematic and PCB adding new symbols and footprints from the default libraries.

I noticed that the README.TXT file in the new disk image still talks about the previous installation process with two installation directories. So it hasn’t been updated along with the software. I assume they will get to that before the final release.

So, a fresh install of the latest V6.0 RC1 on macOS 12.0 works without needing the /Library/Application Support/kicad/ directory anymore.

HTH

Perfect, thank you. I was using v5.1.2 - the last stable build & was trying to use the default paths, but even after trying a couple of installations to the default application support folder, I still wan’t able to connect the libraries with the component data.

As you suggested, I used the nightly build (v6.0) that now puts everything into the single folder. As soon as I opened it, it asked me if I wanted to use the defaults, and this time everything loaded & I can now select & place components on the schematic.

Thank you you again for your help - everything now seems to be working!

Jonathan