Can quit be reassigned a different hotkey from Ctrl-Q on Linux?

I tried under Preferences > Preferences > Hotkeys, and even editing user.hotkeys in the configuration, but it seems to be hardwired to Ctrl-Q by gtk.

I’m tired of exiting KiCad when I type Ctrl-Q instead of Ctrl-W in the editors or 3D viewer out of v5 habit. I would like to assign it something like Ctrl+F12. I suppose I’ll get used to avoiding Ctrl-Q.

Is this the Quit in question?

On my program it is an unassigned command. I tried assigning Q and then F12; both work.
EDIT: Ctrl+F12 works also.

Here’s what I use if it’s any help.

Application: KiCad

Version: 6.0.2-378541a8eb~116~ubuntu20.04.1, release build

wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3

Platform: Linux 5.4.0-100-generic x86_64, 64 bit, Little endian, wxGTK, cinnamon, x11

Build Info:
Date: Feb 11 2022 08:14:15
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OCC: 7.5.2
Curl: 7.81.0
ngspice: 31
Compiler: GCC 9.3.0 with C++ ABI 1013

Build settings:

Strange. I can assign it something like Ctrl+. and this shows up in the user.hotkeys file but the dropdown still shows Ctrl+Q, and unfortunately that is still active, and Ctrl+. doesn’t work. I can’t assign it Ctrl+F12, when I type that the window manager (KDE Plasma) catches that and does what I think is Minimise. Oh well, I’ll keep looking.

It’s a wx thing, it really wants certain “standard” commands linked to certain hotkeys. With KiCad’s command set being so rich I think the only real solution is to totally bypass wx here — something nobody’s really had time to do yet. I’ve been banging my head against this for a while…wanted to build out a nice “single handed” hotkey set for kicad but wx just would not let me have it :slight_smile:


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.