Can I copy traces in footprint to pcb?

I’m trying to export my pcb design to a hyperLynx file for doing EM analysis using openEMS.

Apparently, pcbNew does not include traces inside a footprint when it exports to a hyperLynx file. That’s an issue for me, since I want to evaluate different pcb antennas, and the different designs are encapsulated in footprints.

I tried opening one in the foot print editor, selecting everything, then copy/pasting to the pcb being edited in pcbNew. But, pcbNew still thought the shapes were a footprint and didn’t include the traces in the export.

Is there a different workaround I can use (other than drawing everything again in pcbNew) to get the traces in the footprints “flattened” on the pcb so they get exported?

I have no experience with Hyperlinx, but KiCad does not draw traces (a.k.a tracks) in footprints. KiCad does make a significant distinction between copper tracks and graphical items, even if those graphical items are on a copper layer.

You can add graphical items to a pad in the footprint editor. To do that:

  1. Open the Footprint Editor, load some footprint
  2. Add a pad and select it.
  3. Depress Ctrl + e to enter “pad edit mode”
  4. Draw some graphics. It should overlap with the pad itself, which becomes the attachment point of the normal copper tracks.
  5. When finished, depress Ctrl + e again to end the Pad Edit mode
  6. Save your artwork and use it on a PCB.

I do not know if such a footprint exports properly to Hyperlinx.

Thanks!

Footprints don’t get included in an HyperLynx export, but the pads do.

I didn’t realize I can have an arbitrary pad shape! I’ll give that a try (after writing scripts to basically merge footprints with imported Hyperlinx in OpenEMS) :smiling_face_with_tear:

The footprint polygon ends up having rounded outside corners. Also, the “net tie” keyword doesn’t keep the layout editor from clearing a zone area from the pad.

The rounded corners make the geometry unusable in openEMS. And, I’d have to add a shape to bridge the “zone to pad” clearance the layout editor insists on adding.

If I have to do those operations, it’s not easier than using my script that reads the footprint data and creates the geometry in openEMS

It is interesting that the polygon I created as a footprint directly (versus pad edit mode) did NOT have the rounded corners. No clue why or if I inadvertently did something different when editing the pad.

Polygons have “Line width” which cause rounded corners. It can be set to 0 for filled shapes.

I see, so in FP editor I was designing polygons. So my script could read the shapes without them being corrupted by corner rounding.

Makes sense.

Yes, I can eliminate the rounding in the footprint by setting line width to zero.

Now, if the “net tie” would work. I had it working previously,something must be different now. I’ll revisit soon.