CADSTAR import - no footprints assigned : (

Hello, this is a question about schematic and PCB really.
Just out of interest (I have no real need), I tried importing a random CADSTAR project into the new EAGLE 8.0.0.
I tried this project:

During import (regardless of if I select the .cpa file or the .csa file), I see the following error for schematic:

and the following errors for the PCB:

The result seems to be that each symbol in the schematic has no footprint assigned.

Interestingly, the actual schematic, and the PCB, are both rendered excellently. They appear perfect. But unfortunately unusable since any change in the schematic cannot be updated into the PCB, because there are no footprints for the symbols : (

Is this normal, or a bug with the CADSTAR import? I’ve tried EAGLE import in the past, and it doesn’t have this issue.

If it’s a bug, I’ll go ahead and raise it on GitLab. Many thanks!

Surely you meant the new KiCad 8.0.0? :wink:

1 Like

Yes, sorry! :laughing:
No way I’m ever going back to EAGLE

Created as an issue here:

Does that mean the PCB has all the footprints on it? If so, you can repair the project from there.

  1. PCB Editor / Export / Footrpints to new Library
    • Make it a Project Specific Library.
    • Answer with OK if KiCad asks you to link to this newly created library.
  2. PCB Edtor / Tools / Update Schematic from PCB.

With this second step you can push the updated footprint links back to the schematic. Make sure you know how to handle the Re-link footprints to schematic symbols based on their reference designators option when you do this. (Normallly this option is off, but you may need it depending on the current state of your project.)

1 Like

Hi Paul,
Thanks for this tip! That gets me much further, and I do see the components are linked. However, I subsequently get a crash each time that project is opened, so I’ve raised a separate problem report for that, referencing what I did.
Cannot find component in netlist error, followed by crash if project is saved and re-opened. (#17146) · Issues · KiCad / KiCad Source Code / kicad · GitLab
Hopefully other crashes get higher priority, since it was just a random CADSTAR project. I’m enjoying using KiCad 8’s other new features so far.

Repeatable crashes get a high priority

1 Like

KiCad crashes for me too when I attempt to open the schematic, and I added a comment for that on gitlab.

Did another test. Cloned the CC25xx repository and did the Cadstar import, and as a result KiCad crashed too. I added this info to the other issue you created.

Reproducing a bug is often the most important part of a bug report, and this one is easy to reproduce. I expect it to be fixed in a few days, but to get a newer KiCad version in which the bug is fixed may take a bit longer or be more complicated. Options are

  1. Wait about a month until KiCad V8.0.1
  2. Install KiCad-Nigntly. (Has issues with file format).
  3. Build it yourself.
  4. Maybe a “testing” build will become available?
1 Like

The 8.0 Testing directory is set up on the website, but empty so far

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.