Building KiCad on Windows10 (MSYS2)


#1

Hi,
FYI, I’ve found two showstoppers.

  1. I couldn’t build KiCad with mingw-w64-x86_64-oce 0.17.2-4(KICAD_USE_OCE=ON), due to hard-coded path in OCE-libraries-release.cmake.
    I replaced “C:/building/msys64/” with “C:/msys64/”, I can build it successfully.

  2. I couldn’t build KICAD_SCRIPTING_ACTION_MENU option too.
    If “KICAD_SCRIPTING_ACTION_MENU=ON”, it requires “KICAD_SCRIPTING=OFF.”

I hope it will help.


#2

Hi @starfort_jp if you do not get any reply from a developer here, please post this to https://bugs.launchpad.net/kicad :slight_smile: