Bugs fixed list - where

I’d like to find the list of fixed bugs on the way from 5.1.6 to 5.1.7. Just to know.
I am searching and searching the kicad-pcb.org and don’t know where it is hidden.
I’m sure that when 5.1.6 was published I have seen such list (probably linked here by someone).
Under Help there is something about ‘system related issues’ but where are ‘not system related issues’?

It’s not announced yet but it’s tagged and almost all builds are ready (waiting on osx)

1 Like

Thanks. I have used GitLab only a little (very, very little).
I tried to find how you get that list. When I delete in serach window the Milestone specification I’d expect the shown list is automatically updated or I should have a key to press to ask for update. But don’t know how.
I found that by clicking that window I can select Milestone once more and set ‘=’ and select 5.1.8 and I still have the list for 5.1.7.
I have to be very stupid/blind that I can’t find how to make it working. Where is the ‘Update search results’ key?

To refresh the results press enter with the search field focused (i.e. cursor is blinking in it).
Here are all the milestones by the way: https://gitlab.com/groups/kicad/-/milestones?sort=due_date_desc&state=all

the list linked by qu1ck is the list of closed issues with milestone 5.1.7, if you change 5.1.7 to 5.1.7 you will get a blank list because there is still no closed issues with milestone 5.1.8, but you can take a look a the open issues.

closed issues milestone = 5.1.7
image

open issues milestone = 5.1.8
image

So simple :))))))))))

I got it. So instead of pressing Enter after changing selection rule I can Click Open/Closed/All and I will get the actual list.
My problem was that after pressing ‘x’ mark right to selection rule (Milestone=5.1.7 x) nothing changed.
Then I selected Milestone = and as didn’t found 5.1.7 in search box I entered 5.1.7 manually and at that moment I pressed Enter - but nothing changed as the 5.1.7 list was already there so I did’t noticed Enter has any effect. Then I do the same but as 5.1.8 I selected from list there were no automatic reflex to press Enter (specially that ‘it has no effect’ :slight_smile: ).

The search field of Gitlab acts a bit weirdly and is a bit buggy. It’s not easy to use until you get used to it. I hope it will be fixed.

I agree it takes some getting used to how it works, but I haven’t actually seen bugs before. What bugs do you see?

When trying to delete labels or something. (EDIT: in the search text field.)

Most of the time i get an 'Opss something went wrong on our side, please try again later ’ … it puts the brakes on trying to find out if something has been reported already.

I saw some chat from the developers noting the changelog needed to be sorted for the 5.1.7 release announcement
The Windows release is already out in the “Previous Releases” section