Bug in 6.1 - migrating footprints 5.1 -> 6.1

So let me retrace the steps, sorry for the bad english.

I installed 6.1 while having 5.1 on machine and on prompt to migrate clicked default recommended migrate and it probably “did something”.
6.1 vanilla experience works (same as 5.1 but with buggier track tracer but its too late to go back now since it upgraded projects, 5.1 doesnt want to work on them…) however i noticed i had 0 of my libraries of footprints are there, fine, so i go to manage symbol libraries and add my custom libraries and same for footprints.

I did click migrate libraries so it upgraded the extension, Ok, great.

Open project. Open schematic. I add elements, some vannila and some from the just imported libraries, ok great. Assign footprints. It opens.

Here we have the problem, 0 of my just added footprints are there.

I try re-adding, adding KISYSMOD path in case it likes it better, i go to the footprint editor to see if i can click “Add library” via it, i select a .pretty again, click OK. Added nowhere. Doesnt display in library list on the left just like in the assign footprints. No matter what or where i added the list of footprints it loads in Assign footprints, is always just the default list.
Even if i try to bruteforce it and change KICAD6_FOOTPRINT_DIR to the folder with my custom footprints, it will just say 500 errors that it cant find the default stuff and STILL just show the default stuff (even though it cant find it apparently?). So i’m at a complete loss, its 2AM and this issue is insurmountable and stops me dead in the tracks. I dont know what to do.

EDIT: I originally added a couple of more images, but apparently new users can only put one so one it is…

TL;DR: I add symbol libraries i used in 5.1. Works perfect. I add footprint libraries (.pretty) i used in 5.1. Shows up nowhere nohow.

Hello and welcome @Calsonic

Have you tried:
Open PCB Editor, Open footprint editor ( “Create, delete & edit”) ,
In footprint editor: File / Add library / Select Global or project / Navigate to your Library / Highlight your library then click open.

Your library should now appear in your library list.
Repeat for each library.

1 Like

BTW it’s 6.0.1, not 6.1.

Hello, thank you for your reply!
I tried that in OP, just from the main menu and not PCB editor. For completeness tried it from pcbnew and no dice. I uninstalled 5 and 6.0.1 (thanks for the correction @retiredfeline ), cleaned loose registry files (maybe? ccleaner) and then reinstalled 6.01, and restarted PC.
It still doesnt seem to show up immediately after adding, however when i restart the application it seems to reload all footprints and then the newly added ones do appear! And i can live with that, as long as there’s some way to get them in. :slight_smile:

Hi @Calsonic
Are all your libraries installed and available yet?

Looks like it, things seem to be working now :slight_smile:
Thank you for your help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.