BUG found maybe?

I really hope someone can help me undo this.
Doing my layouts, I use the default, double-click on a footprint to select it like most of us do. Was playing around with hotkeys and decided to add my own hotkey to allow me to switch back to the select tool easily from the route tool.
So I found the command in hotkeys, assigned (control +`), then saved. This worked, but with a huge catch. Now the double-click to select doesn’t work!
So I did what most of us would do, went back into the hotkey prefs and chose “reset to defaults” saved, then tried again. my shortcut was removed, but the double click to select is still disabled.
Next tried to save and closeout kicad. Opened it up again, still can’t select.
Anyone have any suggestions other than uninstall/reinstall?
Thx in advance.

I’m on macOS Monterey

My default for layouts is single left click to select and double left click for properties. That is how it came out of the box.

I’ve never been able to double left click to select.

sorry, I double click out of habit, same for single click. either way, setting the shortcut has broken the ability to select with any click at all.
*note, click to select still works fine in the schem editor tho.

In Preferences > Preferences > PCB Editor > Editing options
you can reset editing options. Maybe that will help?

nope. tried that. arrg

Which hotkey did you select to assign +key?

pretty sure I’ve found a bug. bummer is, I just did an uninstall then reinstall. unfortunately, didn’t fix it.

Sorry, I asked wrong question.
What command did you edit?

Reinstall should not help as problem is probably not in exe and library files but in configuration files.
So instead of reinstalling I would try to delete KiCad configuration files. In Windows it is C:\Users\{User}\AppData\Roaming\kicad directory (for other systems I don’t know). Rename it (to have backup) and run KiCad.

1 Like

Are you sure that this has to do with your hotkey change at all? Maybe you accidentally unchecked footprints in the selection filter in the right sidebar?

1 Like

you sir are correct. I guess setting the shortcut automatically unchecks all those boxes so you have to reselect them. I had no idea thats what those boxes did! even after 2 years of using KiCad, haha.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.