BOM Generator i/o error is a directory

hi i am trying to generate a BOM but am struggling, im running ubuntu, i have been through replacing all my spaces with an underscore as recommended by some other posts i have seen (i was surprised everything still worked after being renamed so there may have been an issue there but it all seems fine).

when i run bom2grouped i get this error code

Run command:
xsltproc -o “/home/mike/Documents/Kicad/Project_Atlas_THT/Project_Atlas” “/usr/share/kicad/plugins/bom2grouped_csv.xsl” “/home/mike/Documents/Kicad/Project_Atlas_THT/Project_Atlas.xml”

Command error. Return code 11
Error messages:
I/O error : Is a directory
I/O error : Is a directory

i ran it as sudo in terminal with the same result, does any one know whats causing this?

What version of kicad?

What are the actual paths (not edited to remove spaces)?

version: 5.1.9-73d0e3b20d~88~ubuntu20.04.1

That is the file path now, i just changed the folder names.
From terminal:
~/Documents/Kicad/Project_Atlas_THT$ pwd
/home/mike/Documents/Kicad/Project_Atlas_THT

I’m not sure if this will fix it, but try changing “/home/mike/Documents/Kicad/Project_Atlas_THT/Project_Atlas” to “/home/mike/Documents/Kicad/Project_Atlas_THT/Project_Atlas.csv”

Note the .csv at the end.

Kicad was recently patched to automatically add the output file extension – will be in 5.1.10 and 6.0. I think that’s later than your version but I can’t tell from your commit hash.

2 Likes

That sorted it, thanks mate. :grin:

2 Likes