BOM generation fails (Win7 vs Win10)


#1

Hello together,

after a while, I upgraded my Windows 7 to Windows 10 and since I’ve done so, the KiCad BOM generation fails. The Windows installation is a clean one and normally I use the nightly build - but the stable one fails as well.

When i run the scripts from terminal, they work fine but this does not create or update the needed XML File. When I run the scripts from KiCAD, all starts with that the Application dont respond for about 5 to 10 minutes and after that the scripts end with an error. Under Windows 7 the scripts only need a few seconds for execution. It seems to me that KiCad is very slow under Windows 10 because starting the Schematic Editor and loading the Libs takes long as well. Remocing my own Part Properties does not change anything.

I hope someone can help me.


#2

Any news on this?
Might be time to hit the bugtracker


#3

You need to be more specific. Which script are you running? What is the error? Which KiCad version?


#4

Recently I tried all of the with KiCad (scripting/plugins folder) delivered scripts i.e. bom2csv.
I’m not sure about the error anymore, because it seems that they complete successful now, but it still takes 10 mintues.
Currently I use the latest nightly build (kicad-r8510)