Board2Pdf v1.1 released in PCM

… to be completed …
PyMuPdf/fitz generates this Message:

PyMuPdf/fitz works here for merging

Thank you @ciondo61 and @tTom!

The message you get Tom is expected if you’re using 7.0.1 and at least one footprint description contains parentheses. It’s solved by downgrading to 7.0.0, upgrading to latest testing build (if there is a testing build for your platform), or by removing all parentheses from all footprint descriptions. Or of course by simply using PyPDF4 until 7.0.2 is released.

I will continue to:

  1. Release 1.2 in PCM.
  2. Update documentation regarding installation of dependencies.
  3. Continue to work in the plugin.
1 Like

I cloned the git to /home/luppa/.var/app/org.kicad.KiCad/data/kicad/7.0/3rdparty/plugins/ , seems to be the correct place under Flatpak install, the icon appears in the toolbar and I can start the plugin.

Same problems still continue, the enabled and disabled layers boxes are empty. I can move templates from the Disabled Templates list to the Enabled Templates list, but I cannot disable any (double-clicking doesn’t work, disable-button does nothing).

I can start KiCad from the command line to see the error output, stuff like this comes out:

Traceback (most recent call last):
  File "/home/luppa/.var/app/org.kicad.KiCad/data/kicad/7.0/3rdparty/plugins/Board2Pdf/dialog/", line 253, in OnTemplateEdit
AttributeError: module 'pcbnew' has no attribute 'BOARD_GetStandardLayerName'
Traceback (most recent call last):
  File "/home/luppa/.var/app/org.kicad.KiCad/data/kicad/7.0/3rdparty/plugins/Board2Pdf/dialog/", line 240, in OnTemplateEdit
  File "/home/luppa/.var/app/org.kicad.KiCad/data/kicad/7.0/3rdparty/plugins/Board2Pdf/dialog/", line 381, in SaveTemplate
    "layers": self.layersColorDict,
AttributeError: 'SettingsDialogPanel' object has no attribute 'layersColorDict'

I think I made an unfortunate choice by starting to use Manjaro. Regular Arch already has packets for 7.0.1, Manjaro is still stuck at 6. Haven’t used (KiCad recommended) FlatPak install before this, looks like a bad choice to sandbox all the system libraries out of it. I think I’m going to starting to move my system to something else than Manjaro and using FlatPak, and only after that start trying KiCad plugins.

I have no idea why you’re getting this error. I’ve never tried Flatpaks so unfortunately not much I can do to help. :confused:

Board2Pdf v1.2 is now available in PCM

If you have problem installing PyMuPDF (fitz), or if you’re having problem with PyMuPDF due to the bug in 7.0.1, please use the PyPDF4 option instead.

I’m not sure if this is helpful or not, but if I start up the python scripting console, and write

>>> import pcbnew
>>> pcbnew.BOARD_getStandardLayerName(0)
Traceback (most recent call last):
  File "<input>", line 1, in <module>
AttributeError: module 'pcbnew' has no attribute 'BOARD_getStandardLayerName'
>>> pcbnew.BOARD.GetStandardLayerName(0)

@luppa Something is not right with your installation. It’s probably better to start a new thread to get help. Include your full version that can be copied from the Help → About menu, describe your flatpak installation and the problems you’re having. Someone with experience of Flatpak installations may be able to help.