Board outline does not form a closed polygon

I am using 5.1.5-3. I checked again and again on the edge cut line connections, and all connections are fine. The copper fill is fine, but DRC keeps on complaining that “Board outline does not form a closed polygon” (Please note the red arrow). The 3D View is wrong too. Are there any other places that I should check?

You see that red arrow pointing to joint between an arc and an edge? Zoom in on it real close and you will see a gap there. Once you fix it run drc again, if there are other issues it will show them with arrows like that.

1 Like

The lines are completely joined. I will edit the post and included the properties of the arc and the line above.

New users cannot add more than one image to the post. So cannot upload any more new images.

Read few threads to become regular user or just upload in a reply instead of first post.

Cannot upload in a reply either.

I believe the problem is not where the arrow is pointing but on the vertical line joining two arcs together, at least on the picture it does not look very continuous.



Zoom in a lot in the area of your read arrow.
Very likely there is a very small gap. It’s one of the quircks of KiCad that the endpoints must match exactly.
You can set a grid size to something convenient for you, then zoom in untill you see white squares on end points. Drag the endponts a bit to the side, release them, and then drag them back to were they (apparently) were. This ensures that the endpoints are placed on the grid, and therefore lineup.

I checked a lot of times already. All connections should be fine. I ran it on Kicad 5.0.1-3 and all works fine. DRC does not report any problems. So, it is not a problem with the file.

Can you view your PCB in: Pcbnew / View / 3D Viewer ?
The 3D viewer is also a bit finicky about errors in board outlines.

If you’ve gained enough “experience” on this forum, you can upload your .kicad-pcb and I’ll have a look at it. It’s an automatic anti-spam measure. I believe you have to read 30+ posts and spend half an hour on the forum or similar.
The exact rules are also somewhere in the forum manual.

Passed DCR on 5.0.1, but have problems with 3D viewer. I have tried what you suggested and now the endpoints matched. Ran through 5.1.5 DCR and 3D Viewer with no problems. Thanks!


5.0.1 did not check the board outline in DRC. That was added in 5.1


I just encountered a similar problem and may have a different solution. If there are small, disconnected lines/arcs/curves on top of your main cut, that seems to confuse the DRC system. Delete any lines on the Edge.Cuts layer which are not part of your outline.

In my situation, I imported the board outline from a .dfx file of the housing and then trimmed out the parts I didn’t need. Once the design was done, I ran the DRC only to receive the “Board outline does not form a closed polygon” message. Much like OP, I was rather certain that my outline was contiguous. Eventually, I just clicked where the arrow pointed and started deleting stuff which wasn’t part of the main outline strokes. Once all of the little lines and arcs were gone, the DRC came back clean.

1 Like

I recently had the same problem. It appears when the position of the center of the arc does not perfectly match the start/end of the lines.
I also noticed one strange thing:
My design passes the DRC but if I want to manually extract the content for another design, the new one will not pass DRC, if things are not in the same order. See the example (2.3 KB)

If there are any extra tracks on the Edge.Cuts layer, even a zero length track on the intersection of two boundary tracks, then this leads to the can’t find board outline error. This happens also when running the 3D viewer. Doing a box selection over the junctions can help find extraneous tracks and you can then delete them.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.