Battery symbol PIN numbers NOT visible

Battery symbol in eeschema (BT single cell) does NOT show the pin numbers. HOWEVER, the pin properties (Symbol Editor) clearly indicates that the pin is marked VISIBLE.

V (5.1.2-1) -1 for OSX


This is what I see in 5.1.4. You are saying the buttons in the lower right are chosen? I’m not sure on your library setup but or much about OSX but you may need to save this to a personal library to make those changes appear because they are not on by default in mine.

Hermit- Thanks for taking a look.

Heres what I see;


OK. This is where the confusion lies. I took this to mean you used the Symbol Editor. :wink: That’s the button to the right side of the image.


No, actually I accessed the SymbolEditor from the eeschema menu.


Welcome to the quirks of KiCad!

I think you can solve your issue in Escheema…

View/Show Hidden Pins

Welcome to the quirks …indeed.

But unfortunately “Show hidden pins” is not the solution

…but thanks for playing!


Don’t I have just one strike?

What about this?


The visibility of pin numbers and names is controlled in the symbols settings not in the pin settings.

Solved! Thanks to everyone that played!

Resolution was as Rene AND Hermit pointed out …the pin visibility control of interest IS INDEED located as shown in their posts. (Library Symbol Properties)

Thanks Rene
Thanks Hermit (I might have solved this from your post alone , the visual clue was there, but my tired old aging laptop screen coupled with my old aging eyes made the “Library Symbol Properties” title of your first posted window almost invisible.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.