Basic printer settings & incorrect printout

Hi, I’ve noticed all along that the basic settings for the printer are always set to portrait format.

The image is not positioned correctly when printing.


Does Plot → PDF place it correctly?

Elektrotechnik.pdf (72.4 KB)

There have been a few fixes in the 7.99 nightly version regarding the printing, and one issue also depends on the wxGTK library/toolkit which is used by KiCad for the user interface and operating system functions like printing. wxGTK 3.2.3 should include that fix, but I have not checked when that will be included in the various OS:es (I only know that fedora 40 will have it, in half a year…).

You could download a nightly, make a copy of your project and try if the printing in 7.99 nightly does the same (unless you already run 7.99 - I don’t remember if you have stated what version of KiCad you run).

Maybe you could also insert the KiCad version information from the “Help” menu in KiCad here. It looks like Windows from your screenshot, but the rest could be interesting too.

1 Like

I also see KiCad verson 7.0.0 on your pdf. The current version is V7.0.8, increments in the third digit are bug fix releases and do not introduce new functionality and you should always install them, but for companies I recommend to wait a week or so, because sometimes ugly things happen.

In general, bug fix releases are made approximately once a month and each has some 60 to 100 bugs fixed. You can read more on the changes in: Release Notes | KiCad EDA

1 Like

For business use, wait until X.0.1 before a major release upgrade and backup your project files first.
7.0.8 is very stable, the fixes in the upcoming 7.0.9 are mostly minor, but useful

Good morning, I wish you a nice winter time. The Uren were changed overnight, and I used the time and updated to KiCad version V7.0.9-rc1. The result is the same, in the PDF it is OK, in the printout it is like the picture above.
In order to use the lesson more sensibly, I drew terminal strips, created PDF files and integrated them into the project folder (1).

Problem, the link is not resolved correctly (2).

${KIPRJMOD}/pdf/N-Klemmblock KN26N.pdf
Strangely enough, it works in the properties dialog (3).

I think that at the moment the variable expansion in the chooser is not supported.
I’m not sure if there already an issue open on GitLab to vote, but i think it should.

GitLab and GitPod etc. are for programmers, I’m not that anymore :laughing: I don’t like logging in everywhere anymore. I also think that the programmers here are reading along and taking notes.
Kind regards, Lutz

Maybe, i’ve seen that sometimes happens that bugs are solved before the issue is open,
but the right place to report issues and request features is over there.

Forum posts are impossible to keep track to.

So when I was a programmer, around 30 years ago, we had so-called to-do lists. But fortunately, as a pensioner, I no longer have to deal with things like that. :grinning:

Sorry, but no – GitLab is the place to report issues and get them solved, not here. The times that someone happens to fix something that they saw here are the rare exception, not the rule.

And how do I get to KiCad…?

From inside KiCad, go to Help → Report Bug and it should take you to the right place.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.