Barrel Jack Layout Connection to Pin 1

I have placed the schematic symbol and made the electrical connections to the connector (+24V and GND). I downloaded the footprint and loaded the component in the design. So far so good. I update the PCB with the new component and everything looks good with one exception. I cannot route to pin 1. A connection guide is shown but I cannot make a connection to pin 1. Pin 2 yes. I have changed the pad geometry and size to mimic pin 2 but it made no difference. This part is placed on the bottom side. I also tried a top side placement and it made no difference. Can somebody help?
For reference…

image (7.5 KB)

The footprint has Edge.Cuts graphics lines inside the pad. SnapEDA is at fault if the footprint in the zip file is unmodified.

1 Like

Hi. All of the net classes are set at default. This is a pretty simple design - nothing high speed. I’m able to route +24V at 39mil to other components. I tried dropping down to 5mils and still cant route out from the pad. See attached. I mimicked all of the pin properties for pin 2 and it still acts the same.

I changed the nets for both pins to +24V and it will not connect. The guide is still present on pin 1.

Thank you “eelik”. I’m kinda new with the use of this tool and trying to understand all of the intricacies. There was an edge cut for pin 1 in the original library component. I removed the edgecut and it is working!
Thanks all!

1 Like

It depends. Oftentimes it’s easier to have pads in their correct locations (with double check, of course) than to position them manually yourself. IMO pad positions and dimensions are the most time consuming part of designing a non-standard footprint in KiCad.

SnapEDA staff are usually responsive and helpful when bugs are pointed out. If the problem is in their conversion process (from some reference format to KiCad), the fix may help many other footprints, too.

Actually they may have someone in this forum, at least in the past it was @Eliictro.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.