Bad/clumsy thing happened today…

Been sitting today with a project, updating a lot in both a schematics and the corresponding PCB. Then I quit KiCad, like 5 hors later, for lunch or so, which of course asks “save?” and by accident I click NO. Yeah I know, we should always save regularly, that’s since old and that’s also what I tell others, but this time it didn’t happen. The question now is: Did those 5 hours simply got up in smoke?

KiCad 6.0+ makes autosaves, unless you disable that feature. Check inside the <project name>-backups folder inside your project directory. By default it’s every 5 minutes.

2 Likes

Thanks, the autosave function is not disabled, but when looking in that folder only old files are there, from 4 days back. The only “fresh” backup is from the unsaved project I opened like 1 hour ago. So…

Ah. You may want to check this option:
image

Otherwise it will only make backups each time you manually save…

For next time.

Thanks, yes that was unchecked, but now it’s checked! Good to get it explained. And 5 hours is not much of a loss, compared to a lifetime, let’s start again…

1 Like

I couldn’t find that dialog box you posted, gkeeth, under Preferences…Preferences.
Where is it?

On the common page.

This is v6

1 Like

Okay, thank you, gkeeth for the extra graphic! I infer that these setttings apply just to the one project, rather than to all projects.

No, they should be global, for all projects.

1 Like

To be clear: the settings to enable backups are global, but when it talks about things like “maximum backups per day” and “maximum total backup size”, those things are per-project.

3 Likes

huh, I actually did not know that.

Haha, be careful so KiCad not will be like Altium, 1000 settings for each part…