Hello everybody,
I’m new to KiCad and I have a question to the background color .
Can I set only black or white ? By years of using Eagle I need some home feeling :slight_smile:

Thx Zh4ng


take care that no other element then has got black as it’s color… for me this were the ‘labels’, so I have them in bright green…

I misread your question… yeah, I think BLK or WHT are the only obvious choices.
If you open the eeschema settings file (on Win7, BZR6097 it’s located in ???:\Users???\AppData\Roaming\kicad) you should be able to see this in line 91:


Now change it to anything from this list (for example ‘ColorBgCanvasEx=Blue 1’) and see how you go:


Hi Joan,
thx for the help.
Can you help me here ?
Can i define the colors in the list itself ?

thx Zh4ng


I don’t know - I guess you would have a chance if you’re modifying the source and rolling your own though?
Which color is missing? The cold blue for the B.Cu layer?

PS: I’d like it too if they’d given us the ability to RGB-value the colors for more choice, but personally can’t complain as I don’t really miss any color.

PPS: you might want to add it to the bug tracker as wish and collect some votes to get this in, but I wouldn’t hold my breath nor count on it to help you to adjust to KiCAD.


Hi Joan,
iam an old Egale user and its hard to change the look and feel. My Eagle Color Environment is a set of dark / light blue and white colors. Nevertheless, i have to live with it. A old Dog “must” learn new tricks :wink:

thx for the support.


I noticed everyone is refering to setting the background color in Eeschema. How does one set the background color in PCBNew? Under the Preferences menu, there is no “Set Colors Scheme” option.


I can’t find a background color related entry in the pbnew ‘ini’ file for my installation…


doesn’t work.


Ultimately what I want to be able to do is print the pcb or a portion of it, just for visual reference when assembling or inspecting the pcb. As it stand, with the default black background color eats up printer ink/toner.


The black background doesn’t print out… it will be white.
As for grey-scale (with copper traces/pads bright grey) and component outlines black and values/references black… there currently is some hamstrung workaround that I use to get this:


Thanks Sparky. Yes, the black will be white when you pirnt the entire pcb. I couldn’t find a way to zoom into and print just a portion of the pcb or for that matter print just the current window view. Thus I’ve resorted to a screen capture, pasting into a paint program then manually replacing the black with white. Any thoughts?


Hm… nasty workaround, you can scale it in the print dialog.
Free selectable in those fields for X/Y… it then seems to zoom in an area to the right/down of the absolute origin.
If you can (for prints) move your board (everything) up there and zoom in how you like, it should work (don’t save the project after printing).
Not very convenient, but I have no better idea, sorry.
Oh, and the frame can be omitted for printing, so shouldn’t be in the way.
Might need a frame template with different zoom levels marked out (so one knows what to expect in the print).

The fixed zooms seem to center on the frame/page (for whatever format you have selected, A4 for me), so getting a handle on what is/will be in the zoomed view is more tricky.


you could export as SVG and than rework in inkscape.
so you can export all layers you want and with an little work get the layers separated in inkscape.
i will do mine this way…


Hello, everyone.
I’ve been using KiCad for about 1 week, and the default colors were beginning to burn my eyes. After a peak at the source, i find that the colors are hard-coded.


const StructColors g_ColorRefs[NBCOLORS] =
{ 0, 0, 0, BLACK, _HKI( “Black” ), DARKDARKGRAY },
{ 72, 72, 72, DARKDARKGRAY, _HKI( “Gray 1” ), DARKGRAY },
{ 132, 132, 132, DARKGRAY, _HKI( “Gray 2” ), LIGHTGRAY },
{ 194, 194, 194, LIGHTGRAY, _HKI( “Gray 3” ), WHITE },
{ 255, 255, 255, WHITE, _HKI( “White” ), WHITE },
{ 194, 255, 255, LIGHTYELLOW, _HKI( “L.Yellow” ), WHITE },
{ 72, 0, 0, DARKBLUE, _HKI( “Blue 1” ), BLUE },
{ 0, 72, 0, DARKGREEN, _HKI( “Green 1” ), GREEN },
{ 72, 72, 0, DARKCYAN, _HKI( “Cyan 1” ), CYAN },
{ 0, 0, 72, DARKRED, _HKI( “Red 1” ), RED },
{ 72, 0, 72, DARKMAGENTA, _HKI( “Magenta 1” ), MAGENTA },
{ 0, 72, 72, DARKBROWN, _HKI( “Brown 1” ), BROWN },
{ 132, 0, 0, BLUE, _HKI( “Blue 2” ), LIGHTBLUE },
{ 0, 132, 0, GREEN, _HKI( “Green 2” ), LIGHTGREEN },
{ 132, 132, 0, CYAN, _HKI( “Cyan 2” ), LIGHTCYAN },
{ 0, 0, 132, RED, _HKI( “Red 2” ), LIGHTRED },
{ 132, 0, 132, MAGENTA, _HKI( “Magenta 2” ), LIGHTMAGENTA },
{ 0, 132, 132, BROWN, _HKI( “Brown 2” ), YELLOW },
{ 194, 0, 0, LIGHTBLUE, _HKI( “Blue 3” ), PUREBLUE, },
{ 0, 194, 0, LIGHTGREEN, _HKI( “Green 3” ), PUREGREEN },
{ 194, 194, 0, LIGHTCYAN, _HKI( “Cyan 3” ), PURECYAN },
{ 0, 0, 194, LIGHTRED, _HKI( “Red 3” ), PURERED },
{ 194, 0, 194, LIGHTMAGENTA, _HKI( “Magenta 3” ), PUREMAGENTA },
{ 0, 194, 194, YELLOW, _HKI( “Yellow 3” ), PUREYELLOW },
{ 255, 0, 0, PUREBLUE, _HKI( “Blue 4” ), WHITE },
{ 0, 255, 0, PUREGREEN, _HKI( “Green 4” ), WHITE },
{ 255, 255, 0, PURECYAN, _HKI( “Cyan 4” ), WHITE },
{ 0, 0, 255, PURERED, _HKI( “Red 4” ), WHITE },
{ 255, 0, 255, PUREMAGENTA, _HKI( “Magenta 4” ), WHITE },
{ 0, 255, 255, PUREYELLOW, _HKI( “Yellow 4” ), WHITE },

Anyways, I am lazy, and I couldn’t get my build environment set up to implement my own solution. plus, i knew exactly what I wanted to change, THE COLORS! i didn’t want to learn whatever the fuck was being used to draw on the screen (I have plenty of other shit to do). It should literally be as easy as choosing your own colors… how is this NOT a feature yet?

To change colors you need to get a hex editor, go to your local KiCad directory, and inside of the bin directory you will find a bunch .kiface files, one for each sub-program in KiCad, pretty much. MAKE COPIES OF THE ORIGINALS. The colors are compiled into each of these files. Just do a search for “C200C2” which is hex for that horrible magenta color. It should be pretty easy to spot the colors, the colors are comprised of only these hex numbers in RGB format: 00, 48, 84, C2, and FF. Just change the colors to whatever you want.

Here’s my original eeschema.kiface file (with highlighted color data), and then there’s my color scheme (after I made my edits):

CAVEAT: There’s some magic going on and the colors are being shifted to something close, not sure why but I have a color scheme I’m happy with so I don’t care.

Default color scheme burn my eyes a lot. And idea color setting to share?

Love your thinking and doing :wink:


Thanks Joan :smiley:

i used this pallette, if anyone’s interested:

There are some deeper brown/rust colors in the db32 palette which probably wont see much use, though…

Here’s another screenshot:

If you compare the displayed colors with what i have available in the program, it looks like some of them are a bit different… this is the magic i was talking about in previous post… I did change the black to a gray, and red#2 to white, so disregard those. Most of the other colors seem different, no? for instance, where the fuck is that deep red at? nowhere! It should be where Green#4 is at. something’s obviously getting lost in translation, here…

One thing to note is that RED #2 (the 16th color) is used in eeschema as the color of the schematic border & info.

also, pcbnew uses the black by default as the background color. try changing it from #000000 to #212121. Look to my previous picture if you’re wondering where the numbers for first color (black) start at, i know there’s a big block of zero’s but they are arranged in a pattern in that file.


another note: the layer colors in pcbnew will act really strangely when you highlight stuff. oh, well.



i have tried to change the color and found the color hex codes in C:/…/kicad/bin/_eeschema.kiface … I have edit the hex codes, but the color in the eescheme doesnt changed…

i dont find the mistake… does this method working today?

Edit: aaaah… i got it… my hex editor doesnt save the hex file with STRG+S … have to choose “save file” manualy


I admire your effort, but the nightly builds you have RGB color picker for every item in eeschema (including background).