Autorefresh of 3D view


#1

Hey everyone!

I noticed that with version 5 the 3D view gets updated after every action in PCBNew. Since this happens even if the viewer is minimized or otherwise not visible on the screen, it is nearly impossible to work on a layout with the viewer open. My current project is a rather big PCB with many components and it takes 1.4s to refresh the view, which means after every action in PCBNew I have to wait this time until I can use PCBNew again. Is there a way to deactivate this feature? Closing and opening the 3D viewer every time is no alternative, I liked the way v4 handled it best (refresh happens only if the viewer window gets focus again).


#2

You could use https://bugs.launchpad.net/kicad and report it as a bug.


#3

I discovered this one time when I had auto-render turned on. I was wondering why my system slowed down significantly every time I made a change on the board until I noticed the re-rendering happening. And this was on a simple test board, not even a dozen components.


#4

It is a bug, if you report it I would be happy to subscribe to the bug report to make it more visible, its has been bugging me for a while.
In kicad 4 it happened only when you had the raytracing enabled, but in kicad 5 it always re-render the 3V view even when the viewer is minimized


#5

It has been reported and discussed since several weeks. Check https://bugs.launchpad.net/kicad/+bug/1785396


#6

Ah, thanks for the link. But I don’t actually think it’s a bug since the behaviour was deliberately changed since v4.


#7

Even deliberate changes can be bugs if there are unintended consequences (in this case the bug only shows it self on some systems. It might be OS or driver dependend. It might depend on 3d model complexity, …)


#8

Another candidate for a checkbox with both options.


#9

That’s what I was thinking, too.