Automatic footprint unstacking

4.0.2 on Ubuntu 64
I am so far unable to unstack the heap of footprints on netlist import.
I have selected the icon and right clicked, but not getting the footprint distribution menu

I’m enjoying the new feature, where you import the netlist while in OpenGL mode and it automatically distributes the footprints. I think that’s been implemented in 4.0.2.

did you click on an empty background?

Tried OpenGL mode and no change in behaviour. I have set up the board outline and clicking in the empty are does nothing.

just so we’re clear, this doesn’t work?:

  1. View > Default Canvas
  2. read netlist and import footprints
  3. activate ‘Mode Footprint’
  4. right click in empty area, have context menu with ‘Global Spread and Place’

PS: I don’t get the option in OpenGL canvas either for BZR6097 and BZR6403 and I have no idea atm where it is for that one?!

Minor updates will only be fairly significant bug fixes rather. You won’t see new features like that being released until 4.1.0.

I don’t know if the autorouting code will be moved over to the GAL (OpenGL and Cairo) backend, because it is so rarely used and not maintained at all. A handful of the devs want it taken out to reduce code maintenance.

That being said - I implemented the spread and place footprints feature so it automatically happens when you import a netlist AND you are using GAL. Like I said to Jules it won’t be released until KiCad 4.1, but it has been in the nightlies for a month.

1 Like

Does that depend on attributes in the footprint like ‘locked’ or something?
Thanks for the info anyway - much appreciated.

So it is a bit different than how it worked before. I’ll explain:

In the nightlies when you import a netlist it will take any new footprints, spread them, and then put them all in “select/move” mode. Then when you exit the netlist import dialog you can place them where ever you would like. Any time you import the netlist and there are new footprints it will do the same thing.

The spread all footprints is missing, but I think what I implemented covers 99.999% of the use cases for it.

1 Like

I tried the feature under Windows 64 4.0.1 and it worked.
Went back to Ubuntu and suddenly I have the menu, though very different in appearance to the Windows version.
Very odd
I love the auto spread, unstacking a heap of resistors manually seems to take longer than doing the tracking.
Am I correct that this does NOT require OpenGL mode

Answering my own question, it seems that the “Global spread and place” is only available on Default canvas, not OpenGL or Cairo

2 Likes