Associating files in Cvpcb


#1

Hi,

I’ve made a schematic, and now I’m trying to associate MOD/PRETTY files with each component. The components show in the right hand screen. Does this mean that I have the PRETTY files or not?

I’ve downloaded the Libraries from Github, but I can only see Ardiuino PRETTY files there, but not individual components. Where Am I going wrong?

P.S. Why are the files now called PRETTY? What does it mean? To me the name MOD for module sounds better!

Cheers, Camerart


#2

A bit of history:
Before Kicad v4 the footprint library has been implemented similary to how the symbol libs are still implemented. There was one big file per library containing all footprints of this library.
This file was called .mod

Along came the new file format where the library is a directory containing one file per footprint.
The directory is called library_name.pretty, the footprints are called footprint_name.kicad_mod

Something similar will be done for the symbol libraries. I think the library directory will have the .sweet name. I am not sure how the symbol files will be called. Maybe .kicad_sym (I’m sure this information can be found somwhere)

As i explained above the .pretty “file” is a directory. You can open it in any file browser to see the .kicad_mod files within it.
To be able to use this library you need to add it to the fp-lib-table.
Open pcb_new and go to preferences->footprint library wizard.
There select files on my computer and navigate to the .pretty directory.
Follow the instructions of the wizard. (If you have problems there, just ask.)

There are filter settings that determine what is displayed in the rightmost column.

Official docu:
http://docs.kicad-pcb.org/4.0.5/en/cvpcb.html


#3

Hi R,

Thanks for your detailed answer.

If I can repeat a question? On your screen shot of the three panes, the right hand shows footprints, as mine does. So does this mean that the PRETTY files are there?

If the files are there, why does the NET not open in PCB?
If the files are not there, then I understand that I must link them.

C.


#4

Having footprints on the right side means you have footprints on your system (cvpcb only shows available footprints) but they are probably not the once you downloaded:

Normally the kicad library is directly downloaded from github everytime the library is needed. (This means you need a constant internet connection and enough data volume.)
If you did not add your downloaded libs by hand to the fp-lib-table then only the footprint libs from github are used.

You can check that by either opening your fp-lib-table in any texteditor. (It is located somewhere in your user folder. In linux it is under ~/.config/kicad/)
Or the better choice is to open the footprint library manager (can be found in pcb_new->preferences)
If the path column of all your entries looks like: ${KIGITHUB}/[Library name].pretty then you use this system. (You always get the latest footprint updates this way.)
If you don’t want that read how do install them locally:

If you have a personal library you need to add it via the library manager as i described above. (I thought you downloaded a non standard library to your system and wanted to know how to add this library to your fp-lib-table)


#5

Hi,

I downloaded these files: https://github.com/KiCad/kicad-library

If I’m offline and open cvpcb nothing happens.
If I’m online and open cvpcb then components show in panel 3 then once a component shows in panel 2 panel 3 empties.

It appears hat even though I downloaded the large Kicad-library file I don’t seem to have them on my computer to use offline.

I would appreciate few word answers, one step at a time please. (otherwise it’s too difficult for me)

C.


#6

I have linked a post in the last answer of mine where @bobc made a step by step instruction on how do to exactly what you want to achieve. It’s a 22 step explanation (post number 14)

By the way you downloaded the symbol and 3d model libraries not the footprint libraries.


#7

Hi R,

I didn’t notice that it was a link.
I’ll let you know how I get on.

By the way you downloaded the symbol and 3d model libraries not the footprint libraries.
No wonder I didn’t get the files, I thought I was getting.

Thanks, including @bobc
C.


#8

Hi R,

I followed the instructions and now I can add components from the downloaded files in kicad_pcb.

Normally I would make a schematic then generate a NET then run cvpcb and associate components and footprints, but I am unable to do it. Is there a step by step way to do this as well?

EDIT:I had to make a number of folders before I was allowed to save the footprints!

C.


#9

You need to run cvpcb before you export the netlist. (I think you know that but just to make sure.)
The order of operations:
Design schematic
Annotate schematic
Run electrical rule check
Associate footprints (cvpcb or directly in the symbol properties. If the later is used it can be done before annotating the schematic.)
export netlist
Design pcb
Possibly iterate through the steps above. But always going top to bottom. (Changing a footprint starts at the associate footprint step and goes down the list.)

(I would interpret this as you solved your problem. But to make sure and to help others who might encounter the same roadblock here a bit of clarification.)

If you save your footprints locally you of course need to save them somewhere where your user has write permission. This means giving your user write permission to the (new) directory where you want your footprints to live. (user = your windows user)


#10

Hi R,

I must have got tangled somewhere! I’m sure its a problem related to: http://docs.kicad-pcb.org/stable/en/cvpcb.html

In Kicad_pcb the right pain is there with components, but once I have saved a schematic and run cvpcb, they disappear. I’m slightly dyslexic, but can still see that I need to associate files accurately.

I’ve happily used Kicad for years now and also had similar problems originally. There must be an easier way, than this.

I think I’ll start again. I’ll have help this time from a person that can follow file systems better than I do.
C.


#11

Hi R,

I’ve been trying ‘none stop’ to get Kicad working, with mixed results. I have two computers and at one time I got both of them to work, then when trying new circuits, they revert to the same problem.

In schematic I can associate the lib files ok. In Kicad_PCB I can associate the PRETTY files ok.

The problem is with CVPCB Here are two frames from a (Poor) video showing what happens. With a component in SCH, when initializing CVPCB the Right frame appears, then as the component show, the right pane disappears and the Left one appears, then I can’t associate the component.

If someone can explain where the link breaks it would be helpful.

C.


#12

Sorry, those pics are useless. :disappointed:

How to get screenshots

  1. Click on the window you want to show
  2. Press ALT+Print Screen
  3. In the forum reply window, press CTRL+V or right click “Paste”

#13

I’m not 100% sure i understand what you mean here. (I would really nead screenshots of good quality.)
Taking a screenshot:
Windows: http://www.wikihow.com/Take-a-Screenshot-in-Microsoft-Windows
Mac: https://support.apple.com/en-us/HT201361
Linux: http://www.thegeekstuff.com/2012/08/screenshot-ubuntu


#14

Hi,

The screenshot method doesn’t work in this case (right pane only), I’m not sure why, so I had to use a camera.

What happens, as CVPCB is run. First the right panel shows the components, then as soon as the left panel shows along with in this case, one component, the right panel disappears, so I am unable to choose the PRETTY file to associate with it.

As mentioned, I have had it working on two computers, but now it doesn’t. I’ve tried a clean re-install.

Uploading…

C.


#15

The menu buttons (and the text at the bottom right of the screen) show that filtering is on for both key words in the symbol and the library selected in the left-hand pane. The currently selected library is the first one, Air_Coils_etc which I guess doesn’t have any footprints matching the key words.

Try disabling filter by library (the button with the L on it) and see if the keyword filter finds any footprints.

Alternatively, turn of filter by keyword (the button two across from the L button) and select likely libraries in the left-hand pane: Housings_DIP or Housings_SOIC.


#16

@hackscribble has the correct answer.
By the way a full explanation of what the filters do is in my first answer in this topic. (Or more precise in the screenshot i provided.)


#17

Hi R and H,

Now I see it, and it’s working ok.

It was a case of can’t see the wood for the trees, and once missed there were many hours of floundering around till now.

I’ve seen other similar cases, and I’m sure that some people may be put off and move to a different application. If you think it would be a good idea, may I suggest that you give advice in smaller bites.

Thanks for your great help.

Camerart.