Assigning Footprints



I have a question about assigning footprints in schematic editor. I am using the nightlies from the Dec. 22nd 2016 or something like that.

  1. What do I put in the footprint field in the component edit window because I tried “DIP-8” quotes excluded, but the CvPcb did not match that with any of the footprints in the Housings_DIP library, I also tried “DIP-8” and Housings_DIP:DIP-8, nothing seems to work when I want the footprints to be associated automatically.

  2. In CvPcb, it lists components by id, however when I made the schematic, I checked digikey to see which footprint was available for which component and now the only want it seems that I can correlate CvPcb and eeschema is by part id, there has got to be a better way? Do I need to assign footprints in each component in eeschema for it to work, give an example of 0805 that would work so that I only am presented with 0805 type footprints in CvPcb whether it’s for hand soldering, or etc.


What happens when you click on the Browse Footprints button with “Housings_DIP:DIP-8” in that field (I assume you edited the footprint value in the Component Properties dialog)?

Does the string look the same when you select the footprint via that button?

What did you put into the value field when you placed the component?
That should give you a clue what you wanted to use.
Pretty cumbersome still…

IMHO I can’t really help you as the way you do this is alien to me.
I got custom libraries where I defined parts instead of symbols, my value field contains strings like these:

  • ATMEGA328P_32-QFP-0.8
  • R_1M-stkple_0805
  • C_100n-50V-X7R-kemet_0805
  • D-ZEHN_D3Z12BF-7_SOD-323F

and each of them has got a footprint pre-defined.


The footprint field needs to exactly match, there is no DIP-8 in my libraries. You could use Housings_DIP:DIP-8_W7.62mm for example.

If you want to filter on a wildcard the footprint field must be blank, and put filter values into the “Footprint Filter” properties of the component. e.g. R_0805*


The problem is that with standard library components you can’t modify the components to add a filter footprint.

I was hoping the footprint field in the schematic editor could be used to enter wildcarded footprints that would significantly narrow down the search in the CvPcb.


Hmm, just stumbled and figured out that double clicking on the component from the Browse Footprints button will assign a footprint to the component I opened. Too bad you can’t use this field to set wildcards as well.
But I guess selecting component footprint from eeschema is what I wanted all along!

The other problem though is the stupid footprint value shows up in the schematic window, and since the footprint name is LIB_NAME:FOOTPRINT_NAME it’s obviously extremely long, and I have to manually unclick the SHOW checkbox for the footprint, anyway I can turn (showing footprint value in schematic) off permanently?


To add footprint filters you would need to create your own components.

I found the footprint display useless as well, but I think to turn off default display of the footprint names, you would need to create your own components…would be useful if there was some global override for it.


Actually, having a problem with the library browser.
So in my last post I clicked on Select Footprints to Browse button, 2nd from the left. Then type in 0805 and clicked Search by Keyword, and it found all the footprint names that had 0805 in it and I thought GREAT, that’s exactly what I wanted.

Then I tried it again on a different component but I selected a library in the navigation menu of the library browser, so now the Load Footprint window with Search by Keyword only searches the library I selected. I cannot deselect and I can’t figure out how to search all the libraries again, fking KiCAD and the devs who paid no attention to UI experience.


EEschema and the underlying concept is a bit worn by now (probably 4 years old, minimum) and the devs currently work on getting it up to the same philosophy and state of art as PCBnew. When the current rag-tag-system was put in place over the years no one wrote a roadmap.
No need to use those words.

Can’t help ya with the “Select Footprints to Browse” function.
My custom fps have no keywords :wink:
But I also can’t deselect a library, so you’re not alone…

The normal way is to use CVpcb to assign footprints to schematic symbols.
As you’re using the tool in a way that wasn’t intended (might even be the first to do it that way afaik) you run into problems, no one else has encountered.

This way I have no problem to get any footprints listed that have 0805 in their name from any library I got.
Then just doubleclick the fp on the right and it get’s assigned in the center to the currently selected REF_ID.


Please note that the text filter/search is only in Nightly builds, not 4.0.5 Stable


OK, so you have to use the keyword button then, should still work the same, or?
Can’t test - have no keywords defined :wink: