Assign footprints: empty libraries

I have installed KiCad a few months ago on my Xubuntu machine, not used it, upgraded it (5.1.10) and now doing a fairly simple project in order to familiarize with it (three symbols only).

I have also discovered two similar posts in this forum, but none held a solution.

In short, when opening “Assign Footprints”, I see a lot of library names on the left side, my three components in the middle, but no footprints on the right side.

Yes, no filters applied in the top section.
Yes, paths look ok. (${KISYSMOD} = /usr/share/kicad/modules/)
Yes, data seems to be there (/usr/share/kicad/modules/Battery.pretty/manyManyfiles.kicad_mod).

Still no footprint visible. I am stuck.
Looking forward to any help. Thank you!

Did you change anything on those path names or variables?
Sometimes it’s a little typo you keep missing even when staring at it.

When I encounter such a situation, I sometimes copy both versions of the text, and paste them on separate lines in a text editor.

For me, it has 43 files with a total size of 216k.

paul@medion:/usr/share/kicad/modules/Battery.pretty$ ls -hl
total 216K
-rw-r–r-- 1 root root 555 Apr 25 18:34 Battery_CR1225.kicad_mod
-rw-r–r-- 1 root root 2,1K Apr 25 18:34 BatteryHolder_Bulgin_BX0036_1xC.kicad_mod

After a complete uninstall and reinstall I noticed there’s a warning message about not finding the libraries. I investigated a bit more and found the path is containing one too many slash and that there is mismatches between the library name and its label (see screenshot).

For testing, I have manually corrected the name of one library and then it would display footprints in the “assign footprint” window.

Is there an easy way to have the library corrected more easily than to check each entry manually?

No, especially after having purged and reinstalled it is absolutely sure that the paths and labels are 100% “original”.

Which “both versions of the text” are you talking about?

I found a solution. There’s a “footprint library manager” window. I deleted all entries and added them fresh by clicking the “folder” icon in the lower section. Then selected all from the modules folder and that made it work.

However, this should be corrected so that new users would not need to do that.

Compare the path name that KiCad uses: KiCad Project Manager / Preferences / Configure Paths with the actual path name used by your operating system to the real location of the files.

If you have not touched these paths an error would be unlikely, but you may have done so

and forgotten.

Has your library setup ever worked in the past? Did you use it back then, or just installed it and got distracted?

As a “dumb resort” it may help to completely uninstall kicad (with --purge) and re-install it. Also make sure that ~/config/kicad gets deleted (or rename it to somewhere KiCad can’t find it. If this configuration does not exist, KiCad should re-create it from a default template.

No. Not ever touched those paths. I just learned about them today (after purge etc.). See my above replies, I actually sorted out the problem and corrected it. As far as I see it, it’s a fault of the installation routine.
Your answer was overlapping mine, I went down the same paths (reinstall, and also checked whether it had deleted any config stuff, which it did. Actually, it was the -auto-remove option which did that for me).

I already suspected I was writing things that would be obvious to you, but it’s hard to estimate sometimes.

Main thing though:

???

apt has an “autoremove”, but thst should only remove unused packages.
If you can document what the solution was for you and post it here, then others may also benefit while searching this forum.

No problem.

I think the actual solution is:

  1. in the library manager on the “global” tab, choose all library entries and hit the “recycle bin” icon, which should remove all entries
  2. the hit the “folder” icon in the lower section. It took me to the folder /usr/share/kicad/modules/ where I selected all existing libraries.

The other stuff was about how I removed my KiCad installation. That is probably not necessary. (And you were right about auto-remove. I did a “sudo apt purge kicad” and found the libraries under /usr/share/kicad still being there. After “sudo apt auto-remove” those were deleted, too.)