Anyone tried svg2mod? I'm having issues

Hey Guys,
not sure if this is the right place to ask for suggestions or not.

I have several svgs that I have drawn and am trying to convert into kicad modules.
Each time I try, i end up getting an empty footprint with just the svg2mod text and nothing else in the result.

I’ve tried my best to follow instructions to the letter, and even tried experimenting with diferent sizes to see if i was just trying to convert something that was too small.

This is the output I get (i’m on mac)

Mac-Pro:svg2mod-master brad$ ./ -i circle_pad_all.svg -o circle.mod -p 0.1
Parsing SVG...
No handler for element {}metadata
No handler for element {}defs
No handler for element {}namedview
transform: matrix [5.7434625, 0.0, 0.0, 5.7434625, -358.57396, -616.14193]
transform: matrix [5.7434625, 0.0, 0.0, 5.7434625, -358.57396, -616.14193]
Writing module file: circle.mod
Mac-Pro:svg2mod-master brad$ 

I have converted objects to paths, saved as inkscape svg, done the layer names and so at this point I am a bit lost…

This is the design I am trying to convert…

So this is going to be a footprint?
Why don’t you construct it with pad primitives and the help of the array feature?

Array feature? Ill have to google that

when you’re in footprint editor and right click on a pad, there is an array option (x/y and circular)… have fun experimenting :wink:

Can you post your svg file?

1 Like

Yes, post your Inkscape .svg file.

I am 90% sure you’re supposed to run both:

  1. Object to Path (Shift+Alt+C)
  2. Stroke to Path (Ctrl+Alt+C)
    …at least this is what the on GitHub says.

Another thing to double check is that you moved the item to the later after you create the layer.

If you go into your .kicad_mod file what do you get? Nothing?

1 Like