Antenna: THT pad clearance error and difficulties to connect trace to it

Hello,

I have downloaded the NFC-antennas.zip from the 5th answer of this topic Where to find NFC Class 6 antenna PCB Schematic for KiCad
The import worked without problems, and I’m very grateful for the footprints. However the DRC throws errors when connecting them and I don’t know how to fix this. (KiCad 6.0.4)

The schematic only consists of the coil and one resistor connected to its terminals.

On the THT pads (“All copper layer” is selected in pad properties) but it does not let me connect two traces on the same layer like on Pad 2 in the picture. Pad 1 is ok since a bottom layer trace connects to a top layer trace. If I try to start routing from the pad it says “cannot start routing from a graphic”.


DRC says clearance error, but the Pad and the trace are the same net.

A workaround I found after some time for Pad 2 is to first connect a bottom layer trace and then manually change the layer of the trace to top.

But the DRC errors are still confusing me.
Some other discussions mention that maybe some graphics are drawn on the copper layer in the footprint and this causes problems. But what are the other options instead of drawing lines in the footprint editor and putting them on the F.Cu layer? Will it work if I send it to the fab with the workaround I used?

Thank you!

Your footprint almost certainly abuses graphic lines as copper tracks. This has been an old hack in KiCad, but as KiCad improves the old hacks tend to break or get removed altogether. In older versions of KiCad, graphics on a copper layer was simply ignored by DRC, while in newer versions DRC recognizes graphics and always keeps a clearance from it, and therefore you can’t reach the pad. It is the only option for KiCad, because graphics do not have net info.

This feature has also been abused for years for net ties. When KiCad became aware of graphics on copper layers the net ties broke, and this was temporarily fixed with another hack, by putting the words “net tie” in the keywords of a footprint. (Open a net tie in the footprint editor and then: Footprint Editor / File / Footprint Properties / General (tab) / Keywords

In the link below I experimented a bit with the pad edit mode. In this mode graphics are attached to a pad and become a part of it, and therefore KiCad and then it becomes a part of the same net as the pad.

1 Like

Thank you, the keyword “net tie” fixed the errors for now. The traces now connect to the pads as usual.