Annoying UI issue - work area regularly "locking up"


#1

I’m using 4.0.7 and I’m having a heck of a time with it constantly “locking up” - the work area iis completely unresponsive to mouse clicks / drags / mouse wheel. This is hugely frustrating. The only “fix” is to either quit and restart KiCad, or just wait for about 1 minute (!) for it to come to life again.

This is really weird because the rest of the UI is functional - buttons, menus etc. Its just the workarea that’s dead. I’ve tried to figure out if there’s something specific that triggers this, but I’ve not been able to determine anything at all - it happens at random, maybe every 10-15 minutes of use.

Has anyone else encountered this significant issue? Would greatly appreciate any suggestions.

I’m using 4.0.7 on Windows10Pro/x64 on a 16GB Corei6/6700K machine with nothing else running.


Mouse buttons freeze after editing
#2

Never came across this issue.

Could you tell us some more clues? Schematic, layout, lib editor?


#3

Going unresponsive but recovering sounds like some Internet file access is going on. You can use Wireshark or Sysinternals tools to look at this


#4

Do you have any project or library files stored on a network drive?


#5

Sorry I should have said this is in the schematic editor (I use the layout editor far less, so not sure if it shows up there too).
This is not related to network access. Nothing is on any network drive.

I think this may have something to do with text entry, as sometimes opening up the “Page Settings” dialog will get things working again.


#6

I just started using KiCAD this weekend, and I noticed this also. For me, it starts working again, if I lift up the main program, and then go back again to the schematic editor.


#7

This is a know issue, AFAIK fixed in v5.


#8

One way I can always seem to trigger this is to edit a component via the menu system rather than hitting the E hotkey. Just pop up the edit component dialog, cancel it, and the workspace is unresponsive. Do the same via the E key and it’s fine.

If it’s fixed in v5 I guess that’s good :slight_smile:


#9

I have exactly the same issue.


#10

On the same operating system or has it spread to a different one?


#11

I had it on Windows but not Linux, at some point it was fixed in nightly builds and I haven’t seen it ever since.


#12

Same for me, the freeze was very annoying


#13

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.