Altium CircuitStudio Pcb file import issue with HOLES

Hi all,

Not sure where to post a possible issue in KiCad V6.

I imported a pcb from Altium CircuitStudio (latest) and the mounting holes I had created in CircuitStudio did not import properly into KiCad. What I got was a pad the ccorrect shape but a very small hole in the centre.

I think I worked out what happened.

In CircuitStudio you cannot create non-plated, pad-less, copperless holes (say Pcb mounting holes).
What you have to do is create a pad with a hole bigger than the pad size specified, and uncheck the ‘plated’ option…so you end up with a simple hole in the FR4.

As far as I can see though, KiCad doesn’t support holes bigger than pads, so when I import this Pcb Kicad reduces the hole size down to a bare minimum.
What I then have to do is deleted the hole/pad and create a KiCad one.

On Altium Designer this isn’t an issue, I believe, because it has more configuration options for pads and so you don’t have to ‘cheat’ like you do in CircuitStudio.

Maybe there’s another way in CircuitStudio, but I never found it.

Thanks,

Ian.

Please post some example board (and perhaps create an issue on gitlab). I can fix it then.

Ok, I do one later this week…cheers.

Hi, consider reviewing your kicad file with text editor (searc and replace hole properties), until this will be resolved from kicad side…

1 Like

Here’s a zip file contaning the CircuitStudio TEST pcb and also screenshots in 2D & 3D from CircuitStudio.
Also, there’s screenshots from KiCad V6.0.

There’s a variety of pads/holes I created in CircuitStudio and you can see from the screenshot showing the properties box that I had created the holes with no copper by making the hole size BIGGER than the pad size as I had described.

Hope thats enough for you to take this issue forward and fix in KiCad.

Ian.
testPCB.zip (969.1 KB)

1 Like

@IanJ I looked onto your board in the 3d-viewer, and I think the holes are imported correctly. The thing differing is, that the solder-mask is above the hole. So it might be a 3d-viewer bug.

Creating gerbers from the imported file into KiCad and viewing them they are messed up also.

Ian.

@IanJ Please create an issue in the bug tracker. This might require some more discussion, and we don’t want to forget it.

Ok, I’ll do that.

Ian.