Allow snap points

Hi (using Kicad 8.0.1 on windows 10).

When drawing a line is there a way to add extra snap point.
For example, if I have a line on the silkscreen layer. and I’m drawing one on the edge cut layer, the mouse will not snap to the start of the line in the silkscreen layer.
Is there a way to allow this snapping point ?

Or If I want to draw a line for the center of a pad.
Or to put a pad at the end of a line (I’m using the line as a guide).

may be there is an option that I’m not aware of to activate some extra snap points.

KiCad’s snapping system is a bit convoluted and distorted.
I’m not sure about the exact rules but I believe that snapping when drawing graphic items only works with graphic items on the same layer. It is a compromise. There are very many items on a crowded PCB, and this makes it logical to have a system to limit the available snapping points at any time. But it can also a bit annoying at some time.

One of the common workarounds is to use the grid origin. You can move the grid origin to the endpoint of the silkscreen line to use it as a reference on another layer. Another option / workaround is to first draw your line on the silkscreen layer, and then edit it properties to put it on another layer. If the line on the silkscreen is not part of a footprint, you can also select it and press [Ctrl + d] to duplicate it, and then modify the copy (layer, or move an endpoint).

In general, it’s not a good Idea to have lines on both the silkscreen and on Edge.Cuts at the same locations. DRC will also complain about this with the message: “Warning: Silkscreen clipped by board edge”

I agree about the DRC issue, but it was an example.
Basicaly, I’m trying to use line a guide to place other stuff.

I’ve found that you can snap a footprint to a line end point by selecting the layer of the line, then grabbing the footprint. At this moment the end point of the line become a magnetic point.

I also use the change layer trick o a line, but I find it painfull.
On some software I’ve seen tricks like pressing CTRL does activate some extra snap points, but that does not seems to be the case with kicad.

The workaround with the grid origin can also be usefull thanks.

v8 introduced option to switch between “snap only to active layer” and “switch to items on all layers”. Search in the Preferences–>hotkey list.


Nice tip. That one is well hidden :slight_smile:

You can find it when searching for “snap” in the hotkey list:


Thanks, that is exactly what I wanted