(All) Symbols loaded every time i want to add a new symbol into the schematic


#1

Hi,

I have not been using KiCAD regularly, so i updated it and wanted to try the new features on the nightly version:

Application: kicad
Version: (2017-12-26 revision 90818afed)-makepkg, release build
Libraries:
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON

My box in Windows 10.

I did a new schematic and as soon as i wanted to add a symbol the libs were loaded (that’s fine for the first time i thought, it took some minutes to do so), so i added a symbol into the schematic, then i wanted to add another symbol and the symbol libs were being loaded again (i don’t remember this were the behavior in past versions of KiCAD).

So i can’t work on the schematic because every time i want to add a symbol it took some minutes to load it (the symbols), i tried removing most of the symbol libs but it didn’t worked as expected (still have to wait so the symbol libs are loaded again).

Is this the expected behavior?
I’m doing something silly? (if you check my Q’s here some of my problems ended up being bugs, so this may be also one).
But most likely i’m missing something obvious since i haven’t used KiCAD in a while.

Regards,
Carlos


#2

There was discussion in the developers mailing list regarding this issue, and I don’t know if it was resolved. They seemed to indicate that it was loading in the background and doesn’t actually need to show the progress bar.

I have noticed that my Ubuntu system reloading all the libraries is not a significant delay, but under Windows it took an annoyingly long time. This seriously impedes workflow.

Hopefully they fix this before the version 5 release.


#3

Guess it is time for the weekly disclaimer regarding nightly builds (should be an FAQ!).

Anyway, nightlies have bugs and you found one. The next thing to do is look on the bug tracker to see if it is reported already, if not report it.

All bugs, most recent first https://bugs.launchpad.net/kicad/+bugs?orderby=-id&start=0

BTW, I think the “loading” message may be a red herring. If libraries are already loaded, they are not reloaded, but the message is displayed anyway. There is some time consuming process occurring after that stage, which is not given a message (probably because the developer did not expect it to take long).

There are also significant differences in GUI performance between OSes, in this case operations that might be quick on Linux are slow on Windows.


#4

Hi,
I Confirm this “bug” present since several nightly versions…
Quite annoying to wait that Kicad loads all libraries at each time. Desactivating unused libraries in the library manager does not reduce the loading time.

Application: kicad
Version: (2017-12-27 revision fab6fc69e)-makepkg, release build
Libraries:
wxWidgets 3.0.3
libcurl/7.54.1 OpenSSL/1.0.2l zlib/1.2.11 libssh2/1.8.0 nghttp2/1.23.1 librtmp/2.3
Platform: Windows 8 (build 9200), 64-bit edition, 64 bit, Little endian, wxMSW
Build Info:
wxWidgets: 3.0.3 (wchar_t,wx containers,compatible with 2.8)
Boost: 1.60.0
Curl: 7.54.1
Compiler: GCC 7.1.0 with C++ ABI 1011

Build settings:
USE_WX_GRAPHICS_CONTEXT=OFF
USE_WX_OVERLAY=OFF
KICAD_SCRIPTING=ON
KICAD_SCRIPTING_MODULES=ON
KICAD_SCRIPTING_WXPYTHON=ON
KICAD_SCRIPTING_ACTION_MENU=ON
BUILD_GITHUB_PLUGIN=ON
KICAD_USE_OCE=ON
KICAD_SPICE=ON


#5

There is already a discussion about this over at the mailing list:
https://www.mail-archive.com/kicad-developers@lists.launchpad.net/msg27147.html


#6

That lends weight to my suspicion that the delay may not be loading libraries.

It might be annoying, but KiCad developers are not telepathic! The way to make it less annoying is please report bugs found in nightly builds on the bug tracker


#7

This bug is already in the launchpad as Bug #1734773.
I added some comments.

Thanks,


#8

I prefer to see the progress bar so i know something is happening, instead of don’t knowing what’s happening.

+1


#9

I know regular users shouldn’t use nightly builds, just use it if you feel adventurous. I did checked the bug list but couldn’t find anything related (from an answer below i know now it’s already reported :smiley: ).

I installed the last stable (4.0.7) and the libs weren’t loaded even in the first time. All worked fine.


#10

Hi,
Thanks for confirming it, i try to confirm this kind of problems before reporting it as bugs :slight_smile:.

Thanks for the link, i will read it.

Well, seems like i have not to report the bug, thanks for adding comments to it :).


#11

Well, seems like i have not to report the bug, thanks for adding comments to it :slight_smile:

But you can at least post your results in the launcgpad at bug # i gave. It will certainly help the authors to find out what’s wrong.
Despite some fixes, i still have the loading delays at each insertion…


#12

Link: https://bugs.launchpad.net/kicad/+bug/1734773


#13

Hi,
The last nightly build is still suffering of this “bug”…
On a rather fast W10 64 bits, it takes about 6-7 seconds on EACH symbol insertion to display the list !

Also, the sorting is quite weird… Try to enter CP (polarized capacitor) and look where you land…

I’m i the ony one ?


#14

Very odd, so I raised it:
https://bugs.launchpad.net/kicad/+bug/1744703


#15

There is a similar bug in Libedit. In both cases it will point to the last found symbol. Could this bug be a remnant or regression from when the list was sorted in the wrong direction (bug #1739412)? Note that just typing in two letters will usually give a lot of search results where the letter combination appears within a symbol name or within a descriptive field, so it scrolls way down.


#16

One character works ok
Two would work better if the priority order was something like

XYspace
XYabc

I don’t look for abcXYefg much and if I did, typing “*XY” in the search box would be acceptable