All 3D parts not appearing in KiCad V5 RC2

I have just upgraded to nightly on Ubuntu, and created a new project (to avoid issues of legacy libraries, etc).

All seems to be working well except that none of the 3D models are showing up.
Paths seem to be set correctly and are pointing to the correct directory, e.g.:
KISYS3DMOD = /usr/share/kicad/modules/packages3d/
I have checked to makes sure the files are indeed in that directory.

If I open footprint editor, load a footprint which has a 3D model, e.g. “R_Axial_DIN0204_L3.6mm_D1.6mm_P1.90mm_Vertical” and click footprint properties -> 3D settings I can see the path looks correct “${KISYS3DMOD}/Resistors_THT.3dshapes/R_Axial_DIN0204_L3.6mm_D1.6mm_P1.90mm_Vertical.wrl”, but in the 3D view I just see the silk-screened pcb.

Any ideas as to what I am missing?

One other odd thing is that when I load Preferences -> manage footprint Libraries. I notice the paths are all pointing to gihub, e.g., ${KIGITHUB}/Battery_Holders.pretty, where ${KIGITHUB} is
I’m pretty sure these libraries are not supported in V5, so this could be the issue. Where can I tell KiCad to use the local footprints instead of Github?

Did you use 4.0.x before you upgraded to nightly builds? There may be some configuration problems. If you don’t use v4 anymore you can delete the config directory, ~/.config/kicad and start from scratch. If you want to keep the possibility to continue with v4 I recommend using different environment variables for v5. See Any ultimate Guide on how to use KiCad 4 and 5 on one System?.


I assume you plan on using the new library structures.

If so then there is your problem: ${KISYS3DMOD}/Resistors_THT.3dshapes

Should be ${KISYS3DMOD}/Resistor_THT.3dshapes if you want to use the new kicad 5 libs. (Library names are now all singular)

So i think @eelik is correct and you still use the old kicad 4 footprint libs. (probably directly from github via the github plugin.)

1 Like

Thank-you both. The problem was indeed due to config issue caused by previous V4. I used the “Add Footprint Libraries Wizard” to add the local libraries, and now the 3D files are showing up.

Rene_Poschl, you are right. I missed the slight change in filename.

So with the new Library structure for Symbols & Footprints on Github, how should one configure the environmental variables to use Github libraries. Do I simply set KICAD_SYMBOL_DIR=
or is it more common practice to clone the repo locally, and point KiCad to that directory.

Sadly the github plugin will no longer work with kicad 5 libs. The reason for that is that there is now only one repo for all footprint libs. So the best option is to download the libs manually from time to time (If you ever want them to update)

Or if you want to update often then you can use git for that.
More details see the library download page:

I see, thanks for the explanation.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.