Aligning large components


I’m wrapping my head about aligning four similiar LED matrix displays so that there’s no gap between them. There are two issues with that in KiCad 6:

  • Snap to grid is inconsistent - the displays are all equal and on the same grid, I just can’t align them properly. At least one of them is always off when they snap to the grid. And when I move them around they go off the grid, clearly visible as their anchor points are just not on the grid any more. I can’t see a pattern behind that and the behaviour seems to be random.
  • Moving a large component in zoom mode is too limited - as soon as the anchor point leaves the visible screen moving is locked in that direction. As such exact placement can only be done with lower zoom values.

Any help is highly appreciated.

you can try changing this setting:
preferences → mouse and touchpad → automatically pan when moving object

Snapping to the grid works, and for me it works consistently, but you have to pay attention to what you snap to the grid. If you select a footprint by a pin, then the anchor point of that pad will be put on the grid. If you select a footprint by it’s center point, then the center point will be put on the grid.

If you first select your 4 footprints, and then right click you also have some functions for modifying their locations. You can use either the Special Tools / Move… commands or one of the functions from Align / Distribute.

Yet another option is to just hover over a footprint, then depress e to edit it’s properties, and then directly enter some X and Y coordinates. A lot of entry boxes also accept simple formula’s. For example if you enter “100 +3*20” into the X coordinate box, then the X coordinate will be set to 160.

1 Like

Similar or same.

If only similar they may have different anchor points.

I also often use Special Tools / Position Relative To… (Shift+P). That allows for exact spacing between footprints. It’s handy when the footprints have consistent anchors/centre points (like “in the middle”), but gets a bit complicated when they don’t :slight_smile:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.