After update to 5.1.0 no 3D models are shown

Hello all,
First post, used Kicad for many years (from Fedora repository) but because 4.2 DRC crash tried to switch to 5.1.0.
Build Kicad from source as described in the docu’s. Works perfectly, well almost…
Kicad works, migrated the libraries, can open old projects (schematics, pcb) no problem.
BUT for some reason I can’t see any 3D models in pcbnew (ALT-3 view), I can see the pcb outline, but no models (yes all options are ticked).
If I open the footprint editor, select a footprint, go to 3D settings it will show a pcb part with the footprint but it will not show the selected 3D model (the *.wrl file is available), even if I select a step file no visual.

Can anyone help?
Is it a library problem, build problem?
Version info:
Application: kicad
Version: 5.1.0, release build
wxWidgets 3.0.4
libcurl/7.59.0 OpenSSL/1.1.0i zlib/1.2.11 libidn2/2.1.1 libpsl/0.20.2 (+libidn2/2.0.4) libssh/0.8.6/openssl/zlib nghttp2/1.32.1
Platform: Linux 4.20.16-100.fc28.x86_64 x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.22
Boost: 1.66.0
OpenCASCADE Community Edition: 6.9.1
Curl: 7.59.0
Compiler: GCC 8.3.1 with C++ ABI 1013

Build settings:


Thanks. I don’t think I have a problem with the libraries. I think I have a problem with rendering the 3D file.
(don’t know how to add a pic here, so do it with ref.)
In this tutorial Tutorial: How to make a footprint in KiCad 5.1.x (From scratch)?
the second picture shows the 3D pic of the selected component. In my case it is a black field, whichever component or *.wrl I select, nothing is shown.
I can select a footprint which is displayed very nice (like first pic) but it looks like the 3D file is not rendered.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.