After Ubuntu upgrade, schematic off grid

Not sure this is a bug or something I’m doing wrong but I have many schematics I created in Ubuntu V18.04. Not long ago I moved (upgraded) to a new full copy of Ubuntu 20.04, and downloaded and installed a new copy of KiCAD.

Now when I open a schematic, everything is off grid. And checking the configuration, I don’t see any way to ‘adjust’ existing schematics to be on grid. As a result, I can’t edit the schematics by adding new parts or anything as nothing mates up when trying to route wires and the like.

When I try to open a project, it tells me that the project already exists and asks if I want to overwrite it? Why is it doing that?

The one time I went ahead and told it to overwrite, that’s when I get the schematic that is all off grid. There is a file ‘rescue-backup’…what is that? What needed rescuing? (The folder is empty, so I wonder why it was created).

What I did was C&P my KiCAD project folder to the new installation of Ubuntu 20.04. I have a KiCAD folder in ‘Home’ in Ubuntu, which is standard practice. Then installed KiCAD. When I try to open a schematic, what are all the errors about? I didn’t C&P any of the KiCAD software.

What do I look for or how do I handle this?


What version of Kicad did you install?

Ver 5.1.5+dfsg1-2build2

The latest I thought.

Have you checked backports? That one is a little out of date and had enough bugs that people were suggesting .6 as the preferred before it was an actual release. .8 is the new hotness.

Dunno what a backport is so doubt I checked it. I went to the KiCAD website and downloaded. What other method is there? :wink:

There was just a thread on that too.

Well, that’s all fine and good, but I didn’t do any of that that I know of.

My guess is that you had a small grid selected when you last worked and now kicad uses a larger one.
I am not sure if the gridsize is part of the project settings or not. If it is part of the project settings then it would be strange if kicad suddenly forgets what the setting was. In that case both versions of kicad (the one before and the one after update) would be interesting.

I don’t recall changing the defaults in either case. So if it is what you suggest, how is it fixed? I don’t see any way to ‘reset’ the grid to a new value.

Yes, this is my problem. My schematic has these issues. I am hoping someone comes up with an automatic fix and I won’t have to rewire all my existing schematics.

Couple of questions.
In creating a new schematic do you experience the same failure?
IE: Save a correct schematic and then reopen
If you right click in schematic window and scroll to grid what grid is checked?
Possible to upload a simple file with failure?

Now it’s getting confusing.
KiCad coordinates do not change on the fly.
KiCad libraries are carefully maintained for each pin to fit on a 50mil grid.

The screenshot posted by MuratUrsavas suggests some kind of scaling issue. Not only for the pin locations, but for all graphics. Have a look at capacitor C49, which is missing one of the plates.
Because of the screenshot size of1795x1066 I strongly suspect this scaling issue is related to HiDpi settings. Murat also used a very small grid.

Murat apparently has this issue with V5.99 while Jim has this with the stable KiCad, but nobody posted complete version info.

Can you first: Eeschema / View / Grid settings and set the grid to “50 mil” and then make a screenshot and post it here?

Do you also use HiDpi settings?
If you do, do the problems go away when using 1:1 scaling?

Right in the middle of chatting with a tech about a Wifi problem. I’ll be back to do what you ask asap. Thanks for the help so far…

@Jim_HiTek please post your kicad version from help->about kicad->copy version information (or similar wording)

Application: Eeschema
Version: 5.1.5+dfsg1-2build2, release build
wxWidgets 3.0.4
libcurl/7.68.0 OpenSSL/1.1.1f zlib/1.2.11 brotli/1.0.7 libidn2/2.2.0 libpsl/0.21.0 (+libidn2/2.2.0) libssh/0.9.3/openssl/zlib nghttp2/1.40.0 librtmp/2.3
Platform: Linux 5.4.0-53-generic x86_64, 64 bit, Little endian, wxGTK
Build Info:
wxWidgets: 3.0.4 (wchar_t,wx containers,compatible with 2.8) GTK+ 3.24
Boost: 1.71.0
OpenCASCADE Technology: 7.3.0
Curl: 7.68.0
Compiler: GCC 9.3.0 with C++ ABI 1013
Build settings:

Okay, thanks for the help…KiCAD was on 50 mil grid and I changed it to 10 mil so everything is back to normal now. I think. Seems to be anyway. My help files seem to have disappeared or weren’t ever installed so I couldn’t find how to adjust the grid. Thanks! Now I know.

I don’t see anyway to write ‘SOLVED’ on this thread…atm anyway.

As I only use the Eeschema portion of program (5.1.8) not sure if you should be designing at 10mil. From what I have read 50mil as per

[quote=“paulvdh, post:13, topic:25964”]
KiCad libraries are carefully maintained for each pin to fit on a 50mil grid.
[/quote] is preferred.

Great. Something else to have to adjust to.

You don’t necessary need to use the same grid as others. The only real restriction is that you can not use a grid larger than what your symbols are designed for. Symbols in the official lib use 50 mil for their pins. Which means if you ever want to use one of them then you should use 50 mil or smaller.

1 Like