Adding fields in Symbol Fields table is not saved?

In the window Tools → Edit Symbol Fields there’s an option to Add Field… to the left. If I add, say, MPN and press Apply, Save Schematic & Continue, it is not there when I open the window again.

I can though add fields by Preferences → Preferences… → Schematic Editor → Field Name Templates. If added here, they also show up in the beforementioned window.

Is it expected behavior?

1 Like

Yes. It will only save fields which have a value assigned.

That’s strange behaviour, especially when you have an Apply- and Save button.

Not really.

Schematic Editor / Tools / Edit Symbol Fields Does not have data of it’s own, but it collects data on the fly from all your schematic symbols and presents it to you (and it lets you edit, and save the changes).

If it would create fields in all the schematic symbols for all the columns then you would have a data explosion. Just imagine having a big schematic, and then importing a few symbols from external libraries that have different names for “manufacturer part numbers” " ordering numbers" etc.

Therefore, the chosen algorithm to only create fields in schematic symbols if they actually have data in them is the sane compromise.

See also: Empty field value in symbol properties triggers automatic deletion of the field entry (#4296) · Issues · KiCad / KiCad Source Code / kicad · GitLab

In the link to gitlab that JeffYoung posted they mention: Schematic Editor / Preferences / Preferences / Schematic Editor / Field Name Templates. Names you add there are always available as columns in your Edit symbol Fields grid cell editor.

I see, the decision is rationalized. But I still think it’s unexpected behavior. Maybe add a popup that says “You have created new fields that do not contain any values. If you close the window they will be deleted”.


A good solution to that ergonomic problem.

I have already posted a link to this thread to a Kicad user suffering the same problem.
@HSPalm Your suggestion should at least be “wishlisted” to the bug reports on Gitlab.

But what if the value is emptied after having been previously filled? Does the software delete the field on save? If so then perhaps the appropriate message for the entire lifecycle might be: Field <name> does not contain any value and will be deleted on save.


Our plan is to just allow empty fields. Hopefully in 7.0, but it’s not at the top of the priority list.


Bad solution (for me)
I hate senseless nag screens that treat me as if I’m 8 years old.

I do agree with JeffYoung though.
I understand some people expect this behavior, so having it configurable in the settings makes sense.

1 Like

Maybe for you, but for others it may resolve senseless confusion, wasted time, and those WTF moments.
Anyway, problem solved soon:

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.