Adding a logo with the conversion tool


#1

Hello!

I have looked at the forum’s earlier messages in order to find a howto for adding logos. I found an idea in these previous posts, that consists in treating a logo like a component. It makes sense, so that’s what I tried to do.

Here is my experiment:

  1. Choose an image (not very original here, I use a japanese flag).

  1. Check how the BW image looks like.

  2. Convert to eeschame’s lib in order to make the symbol part.
    It looks like this.

03JPFLAG

Ok, maybe because I’m supposed to choose negative. I tried to change it, and I get what I wanted04PFLAG

  1. Now I want to create the .pretty part of the component, but… there is no export to .pretty
    format.
    I tried to export a PcbNew(.kicad_mod) file, but I cannot add it to my libs, the browser doesn’t see
    the .kicad_mod file.
    What should I do next?

Thanks,

Pascal


#2

.kicad_mod represents single footprints. .pretty is a directory combining multiple footprints into a library. More details see: Library management in KiCad version 5


#3

in short, that .kicad_mod need to be placed in a .pretty folder that is referenced by footprint lib. table from KiCad.


#4

Hello!
Thnaks for your replies.
I have created a folder Logos.pretty and put the logo.kicad_mod inside. Then I have added the
Logos library with the library manager as I’m used to do it with regular components. As I did this
about 10 times for components now, I guess I did it right, but something is still missing.
I can add the logo to the schematic.
By double-clicking the schematic logo, I can add it a footprint which now displays in the menus.
But when I update the board from schematic, it doesn’t add the logo to the PCB.
I noticed something strange. In case the logo is here but possibly not shown, I tried to search
by name. As its generic name is G and there should be only one, I search G1, and I have no
result. And I noticed that there is no name or reference attached to the logo in the schematic,
alhough this info exists in the editor. This is the picture I get in the editor.
Logo1
And on the schematic, the picture is a few messages above. Is there a reason why the labels
disappear? Is it because there are no electrical contacts?
Thanks,
Pascal


#5

The reference designator for your logo has a hash mark before the G. That is used by KiCad to designate schematic only items (will not show on the PCB, will not show in the BOM). Remove the hash mark, replace the question mark with a number, and then you should see it on your board after you update the board from the schematic.


#6

Hello!

Thanks for your reply. In fact, I accidently removed the hash and it worked, but I didn’t know why it worked. Now I know! Thanks!

Pascal


#7

The hashmark preceding reference designators is also how the system avoids littering up your PCB (and BOM) with all those power and ground symbols. You can use the hashmark for indicating off board components, except that I’m not sure how to get on the BOM but not on the PCB (which is why I would avoid suggesting using this trick for sockets and/or fuse clips).